UVA 573 (暑假-数学 -F - The Snail)


 The Snail 

A snail is at the bottom of a 6-foot well and wants to climb to the top.The snail can climb 3 feetwhile the sun is up, but slides down 1 foot at night while sleeping.The snail has a fatigue factorof 10%, which means that on each successive day the snail climbs10% $\times$3 = 0.3 feet less thanit did the previous day. (The distance lost to fatigue is always 10% of thefirst day's climbingdistance.) On what day does the snail leave the well, i.e., what is the firstday during whichthe snail's height exceeds 6 feet? (A day consists of a period of sunlightfollowed by a period ofdarkness.) As you can see from the following table, the snail leaves the wellduring the third day.

DayInitial HeightDistance ClimbedHeight After ClimbingHeight After Sliding
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-

Your job is to solve this problem in general. Depending on the parametersof the problem, thesnail will eventually either leave the well or slide back to the bottom ofthe well. (In other words,the snail's height will exceed the height of the well or become negative.)You must find out whichhappens first and on what day.

Input 

The input file contains one or more test cases, each on a line by itself.Each line contains fourintegers H, U, D, and F, separated by a single space. If H= 0 it signals the end of the input;otherwise, all four numbers will be between 1 and 100, inclusive. H is theheight of the well infeet, U is the distance in feet that the snail can climb during the day, D is the distance in feetthat the snail slides down during the night, and F is the fatigue factorexpressed as a percentage.The snail never climbs a negative distance. If the fatigue factor dropsthe snail's climbing distancebelow zero, the snail does not climb at all that day. Regardless of how farthe snail climbed, it always slides D feet at night.

Output 


For each test case, output a line indicating whether the snail succeeded(left the well) or failed(slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input 

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output 

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2
#include <cstdio>

int main() {
	double H, U, D, F;
	while (scanf("%lf%lf%lf%lf", &H, &U, &D, &F) && (H || U || D || F)) {
		double height = 0, down = U * F / 100.0;
		int	count = 1;	
		while (1) {
			if (U > 0)
				height += U;
			if (height > H) {
				printf("success on day %d\n", count);
				break;
			}
			height -= D, U -= down;
			if (height < 0 ) {
				printf("failure on day %d\n", count);
				break;
			}
			count++;
		}
	}
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

冰阔落

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值