You are attempting to build with the incorrect version of java

原创 2013年12月04日 11:42:18

Ubuntu 12.04  build android source code

 The error:

Checking build tools versions...
************************************************************
You are attempting to build with the incorrect version
of java.
 
Your version is: java version "1.6.0_45".
The correct version is: Java SE 1.6.
 
Please follow the machine setup instructions at
    http://source.android.com/source/download.html
************************************************************
build/core/main.mk:145: *** stop.  Stop.

solve:
Commenting out the $(error stop) statement from build/core/main.mk on line 131 will allow compilation to proceed:

    # $(error stop)
    endif


end: make -j4


 Recommended Reference: 

http://blog.markloiseau.com/2012/07/how-to-compile-android-on-ubuntu-12-04/

相关文章推荐

You are attempting to build with the incorrect version of java.

You are attempting to build with the incorrect version of java. Android平台的代码 1 安装工具repo :    cu...

Java SSH工程报错 Are you running on Java 1.4 or below with Apache Crimson? Upgrade to Apache Xerces (or Java 1.5) for full XSD suppo

问题描述ERROR [org.springframework.web.context.ContextLoader] - Context initialization failedorg.springf...

maven javadoc plugin build fails with Java 8 when Javadoc tags are incomplete

本地开发环境JDK版本是1.7,生成Javadoc没有问题,在测试环境使用Jenkins自动构建时报错(测试服务器JDK版本是1.8),log如下:/home/andreas/workspaces/c...
  • FX_SKY
  • FX_SKY
  • 2017年01月20日 18:09
  • 1188

java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this a

java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this a...

java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this a

微信支付它给的WXPayEntryActivity主题改错了java.lang.RuntimeException: Unable to start activity ComponentInfo{包名/...

【Java+Maven】问题系列——Cannot change version of project facet Dynamic Web Module to XX.XX

网上搜了好多,都是说将.settings文件夹下的org.eclipse.wst.common.project.facet.core.xml文件中的jst.web改为你需要的版本,例如2.5. ...

2017 浙江省赛 C What Kind of Friends Are You + D Let's Chat

What Kind of Friends Are You Let's Chat
  • ly59782
  • ly59782
  • 2017年04月22日 18:26
  • 1055
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:You are attempting to build with the incorrect version of java
举报原因:
原因补充:

(最多只允许输入30个字)