POJ 1157(DP ,数塔问题)

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21394 Accepted: 9895

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

Input

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

题意:假设以最美观的方式布置花店的橱窗,有 F 束花,每束花的品种都不一样,同时,至少有同样数量的花瓶,被按顺序摆成一行,花瓶的位置是固定的,并从左到右,从 1 到 V 顺序编号, V  是花瓶的数目,编号为 1 的花瓶在最左边,编号为 V 的花瓶在最右边,花束可以移动,并且每束花用 1 到 F  的整数惟一标识,标识花束的整数决定了花束在花瓶中列的顺序即如果 I < J,则花束 I  必须放在花束 J 左边的花瓶中。例如,假设杜鹃花的标识数为 1 ,秋海棠的标识数为 2,康乃馨的标识数为 3,所有的花束在放人花瓶时必须保持其标识数的顺序,即:杜鹃花必须放在秋海棠左边的花瓶中,秋海棠必须放在康乃馨左边的花瓶中。如果花瓶的数目大于花束的数目,则多余的花瓶必须空,即每个花瓶中只能放一束花。 每一个花瓶的形状和颜色也不相同,因此,当各个花瓶中放人不同的花束时会产生不同的美学效果,并以美学值(一个整数)来表示,空置花瓶的美学值为 0。

在上述例子中,花瓶与花束的不同搭配所具有的美学值,可以用如下表格表示。    根据表格,杜鹃花放在花瓶 2 中,会显得非常好看,但若放在花瓶 4 中则显得很难看。
为取得最佳美学效果,必须在保持花束顺序的前提下,使花的摆放取得最大的美学值,如果具有最大美学值的摆放方式不止一种,则输出任何一种方案即可。题中数据满足下面条件:1≤F≤100,F≤V≤100,-50≤AIJ≤50,其中 AII 是花束 I 摆放在花瓶 J 中的美学值。输入整数 F ,V  和矩阵(AIJ) ,输出最大美学值和每束花摆放在各个花瓶中的花瓶编号。


分析:DP,有两种状态表示。

第一种:dp【i】【j】表示前i朵花插在前j个瓶子并且第 i 朵花插在第 j 个瓶子时的最大价值。时间复杂度O(n*m^2)不过可以优化成O(n*m)

状态转移:dp【i】【j】=max(dp【i-1】【k】+p【i】【j】)(i<=k<=j);


第二种:dp【i】【j】表示前i朵花插在前j个瓶子的最大价值。时间复杂度O(n*m)

状态转移:dp【i】【j】=max(dp【i】【j-1】,dp【i-1】【j-1】+p【i】【j】);


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(a,b,c) for(int a=b;a<c;a++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;
const ll mod=1000000007;
int n,m,maxx,minn,cur,l;
int p[110][110],dp[110][110],la[110];
int main(){
    while(cin>>n>>m){
        rep(i,1,n+1)rep(j,1,m+1)scanf("%d",p[i]+j),dp[i][j]=-inf,dp[0][j]=inf;
        la[0]=-inf;
        rep(i,1,m+1)dp[1][i]=p[1][i],la[i]=max(la[i-1],p[1][i]);
        maxx=-inf;
        for(int i=2;i<=n;i++){
            for(int j=i;j<=m;j++){
//第二种方法简化,用 la 数组保存上一步 1~j 区间最大值。
                dp[i][j]=la[j-1]+p[i][j];
                if(j==i+1)la[j-1]=dp[i][j-1];
                else la[j-1]=max(la[j-2],dp[i][j-1]);
//
/*第二种方法不简化
                for(int k=1;k<j;k++){
                    dp[i][j]=max(dp[i][j],dp[i-1][k]+p[i][j]);

                }
*/
            }
            la[m]=max(la[m-1],dp[i][m]);
        }
        rep(i,1,m+1)maxx=max(maxx,dp[n][i]);
        printf("%d\n",maxx);
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值