poj 3159 Candies 邻接表+优先级队列+dijkstra

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 14571 Accepted: 3741

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.
fq是幼稚园班上的老大,一天老师给小朋友们买了一堆的糖果,由fq来分发,在班上,fq和llw是死对头,两人势如水火,不能相容,因此fq希望自己分得的糖果数尽量多余llw,而对于其他小朋友而言,不患寡而患不均的意识甚是强烈,比如A小朋友强烈希望自己的糖果数不能少于B小朋友m个,即B-A<=m,A,B分别为A、B小朋友的分得的糖果数。如此,班上的小朋友存在若干这样的意识,题目要求你在满足其他小朋友的要求的情况下,使fq和llw分得的糖果数差别最大,即max(VN-V1),VN为fq获得的糖果数,V1为llw获得的糖果数。
    因此根据题意,可以列出如下的不等式:
    Vb1-Va1 <= a1b1
    Vb2-Va2 <= a1b2    (1)
      .....
    Vbm-Vam <= ambm               
    目标函数为:max(VN-V1)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
//邻接表+优先级队列+dijkstra
const int maxn=160000;
const int inf=(1<<27);
struct edge
{
    int t,w;//s->t=w;
    int next;//s->的下一个定点
};
int p[maxn];//表头结点 初值-1
edge G[maxn];//邻接表
int l;//邻接表  初值0
int V,E;//点数 边数
//添加边
void addedge(int u,int v,int w)
{
    G[l].t=v;
    G[l].w=w;
    G[l].next=p[u];
    p[u]=l++;
}
//计算从s0到其他点的最短距离
struct CNode
{
    int k,w;//s0->k=w;
};
bool operator < ( const CNode & d1, const CNode & d2 ) {
 return d1.w > d2.w;   //priority_queue总是将最大的元素出列
}
priority_queue<CNode> q;
bool vis[maxn];
int dis[maxn];//s0到其他点的最短距离
CNode tmp;//temp
void priority_queue_dijkstra(int s0)
{
    memset(vis,0,sizeof(vis));
    memset(dis,-1,sizeof(dis));
    tmp.k=s0,tmp.w=0;
    q.push(tmp);
    while(!q.empty())
    {
        tmp=q.top();q.pop();
        if(vis[tmp.k]) continue;
        vis[tmp.k]=true;
        dis[tmp.k]=tmp.w;
        for(int i=p[tmp.k];i!=-1;i=G[i].next)
        {
            CNode t;
            t.k=G[i].t;
            if(vis[t.k]) continue;
            t.w=tmp.w+G[i].w;
            q.push(t);
        }
    }
}
int main()
{
    while(scanf("%d%d",&V,&E)==2)
    {
        memset(p,-1,sizeof(p));//important
        l=0;//important
        for(int i=0;i<E;i++)
        {
            int u,v,w;scanf("%d%d%d",&u,&v,&w);//从1开始
            //u->v=w
            addedge(u,v,w);
        }
        priority_queue_dijkstra(1);
        printf("%d/n",dis[V]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值