关闭

jquery eclipse 下报错 但可正常使用

标签: eclipsejquery
346人阅读 评论(0) 收藏 举报
使用Eclipse 3.7及以上版本时,工程中加入jquery.min.js文件,发现该文件出现错误提示(红×),但使用Eclipse 3.7以前的版本就不会出现这种提示。是因为Eclipse 3.7在.project配置文件中,加入了JS验证框架org.eclipse.wst.jsdt.core.javascriptValidator。加入该框架后,如果js文件书写规则不符合规范就会报错。但是工程仍然可以正常运行。于是考虑为了不让错误提示影响心情,删之。工程亦可正常运行。
        操作如下:
        在该工程根目录下,找到 .project文件,用文件编辑器打开,将<buildSpec>节点下的<name>值为org.eclipse.wst.jsdt.core.javascriptValidator的<biildCommand>删除,之后再将<natures>节点下值为org.eclipse.wst.jsdt.core.jsNature的<nature>删除即可。如图:(方框标示部分)
        
        删除之后,保存文件。回到Eclipse中发现还是报错,将该文件内容全选、剪切、保存、再粘贴、保存。就可以将错误提示清除。
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:3150次
    • 积分:53
    • 等级:
    • 排名:千里之外
    • 原创:1篇
    • 转载:5篇
    • 译文:0篇
    • 评论:0条
    文章存档