关闭

校园网内利用Openwrt+PPTP实现全校范围内联网

标签: openwrt校园网pptp
1842人阅读 评论(0) 收藏 举报
分类:

因为要寝室、实验室两头奔波,而路由器设在寝室,经常忘记断网导致去实验室后无法联网Orz

所以搭建vpn,需要上网就直接通过校园网连接路由器,然后上外网。


基本思路就是:

                  PPTP VPN                                          NetKeeper               

实验室----------------------->OpenWrt路由器---------------------->外网


环境:

cqupt校园网(内网ip是172开头)

netkeeper拨号上网(2.5.0092)

网件wndr3800路由器(openwrt  CC 15.05.1)


先决条件:

校园网能互联

路由器能拨号上外网

路由器能安装pptpd(openvpn也行,但是太麻烦)


确保以上条件后就可以开始了:

step 1 刷路由器:

上X宝买一台路由器,然后去 https://downloads.openwrt.org/ 下载 Chaos Calmer 15.05/15.05.01 版本的;

刷好后,浏览器进192.168.1.1,设置密码;

然后下载WinScp和Putty。

tips:

Barrier Breaker 14.07的pptpd配置和15.05的不一样如果是14.07版本的就自己去查资料啦

不推荐PandoraBox //我的xiaomi r1cl 刷的PandoraBox,opkg update始终失败Orz


extra step 1 Netkeeper:

这一步是配置校园网拨号

根据自己学习的实际情况来吧。。。

NetKeeper的可以看这个:https://github.com/miao1007/Openwrt-NetKeeper

保证能够联网就可以了


step 2 opkg install:

可以连外网的话,就可以开始了:

PuTTY连接路由器

login as:

root

password for root:

#你自己的密码


显示openwrt的标志就是成功了,接下来就

opkg update;

opkg install pptpd kmod-mppe;


然后路由器就会下载pptp server的相关包

下子完成后继续

vi /etc/config/pptpd


大概长这样的:

config service 'pptpd'
	option 'enabled' '1'
	option 'localip' ‘xxx.yyy.www.zzz’ #本地ip,就填192.168.1.1吧


config 'login' #pptp帐户选项,想多一个帐户就把这个多复制一个好了
	option 'username' ‘foo’#用户名
	option 'password' ‘bar’#密码
	option 'remoteip' 'xxx.yyy.zzz.1’#这个帐户的ip


config 'login' 
	option 'username' ‘foo’
	option 'password' ‘bar’
	option 'remoteip' 'xxx.yyy.zzz.2’

弄好后就配防火墙

vi /etc/config/network

在最底下添加

config rule
	option target 'ACCEPT'
	option _name 'pptp'
	option src 'wan'
	option proto 'tcp'
	option dest_port '1723'

config rule
	option target 'ACCEPT'
	option _name 'gre'
	option src 'wan'
	option proto '47'

然后, vi /etc/firewall.user

在最底下添加

# Allow all traffic in and out of the ppp interface. No reason to specify nets.
iptables -A input_rule -i ppp+ -j ACCEPT
iptables -A output_rule -o ppp+ -j ACCEPT
# This rule will allow traffic towards internet
iptables -A forwarding_rule -i ppp+ -j ACCEPT
iptables -A forwarding_rule -o ppp+ -j ACCEPT
弄好后就打开pptp服务

/etc/init.d/pptpd enable
/etc/init.d/pptpd start

tip:

进入vim,先按i才能插入内容,shift+insert粘贴,最后点esc退出插入模式,输入 :x保存退出

如果是现在还是直接连上的路由器,可以连路由器试一下,讲道理这样就可以通过pptp上外网了


step 3 静态路由

现在这种状态还不能直接通过校园网连路由器的,因为校园网路由器和实验室的网不在同一网段,所以就要添加静态路由

先去实验室,把电脑插上网线,然后在cmd中输入ipconfig,记下ipv4地址(xxx.yyy.zzz.ppp)、网关(一般都是xxx.yyy.zzz.1)、子网掩码

然后先办法通过外网用vpn连上路由器,进luci->网络->静态路由里面添加 静态IPv4路由

接口->wan
对象->xxx.yyy.zzz.0
IPv4-子网掩码->子网掩码
IPv4-网关->网关
跃点数->20
MTU->不要改,默认1500
点 保存&应用
这下就可以从实验室联网了~


#啥,你告诉我你无法从外网连pptp到路由器?

#那你就老老实实走回去添加吧~



其他的等有空再补充了Orz



参考文献:

https://wiki.openwrt.org/doc/howto/vpn.server.pptpd





0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    文章分类
    文章存档