HHUOJ LCM and Walk 数学 逆推 gcd&lcm DFS TWT Tokyo Olympic 2Combo -1

问题 D: LCM and Walk

时间限制: 1 Sec 内存限制: 128 MB
提交: 7 解决: 4
[ 提交][ 状态][ 讨论版]

题目描述

Jerry has just learned some number theory, and can't wait to show his ability to Tom.

Now Jerry is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first Jerry is standing at grid (sx,sy), and begins his journey.

To show Tom his talents in math, he uses a special way of walk. If currently Jerry is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and walk exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell Jerry the number of possible starting grids that can reach (ex,ey)!

输入

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.
⋅ 1≤ex,ey≤10 9.

输出

For every test case, you should output "Case #x: y", where x indicates the case number and counts from 1 and y is the number of possible starting grids.

样例输入

3
6 10
6 8
2 8

样例输出

Case #1: 1
Case #2: 2
Case #3: 3

啊。。。。一开始在纸上写写写没啥门道。。zhangjiatao1就给了我小提示。。。继续写写写。。。、

题目给了我们(ex,ey),从起点经过有限次的移动会到达(ex,ey)。要求我们求出起点有多少种可能,移动的规则是只能向右或向上移动,并且移动的步长为lcm(x,y)。

如果起始位置为(sx,sy),我们保证sx总大于sy,那么下一步就会是(sx+lcm(sx,sy),sy),将(x,y)分解为(kx,ky)(k=gcd(kx,ky)),那么下一步就为(kx+(kxky)/k,ky)。

还是用图吧。。


很容易发现,从第一步走到最后一步这其中的gcd都是不变的,那么上式中k、x、y都可知

然而还是写不对。。。。zhangjiatao1就把想飞菜鸡的推导过程给我看了。。。强啊。。。


就是每一步都判断一下x是否能被(1+y/gcd)整除就行了

下面代码:

#include <cstdlib>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
long long ex,ey;
long long gcd(long long  a,long long b){
    return b==0?a:gcd(b,a%b);
}

int main(){
    int t;
    scanf("%d",&t);
    int rnd=1;
    while(t--){
        scanf("%lld%lld",&ex,&ey);
        if(ex==ey){
            printf("Case #%d: 1\n",rnd);
            rnd++;
            continue;
        }
        long long lcm_n,gcd_n;
        gcd_n=gcd(ex,ey);
        lcm_n=ex*ey/gcd_n;
        long long ans=1;
        while(1){
            if(ex==ey){
                break;
            }
            if(ex<ey){
                swap(ex,ey);
            }
            if((ex/gcd_n)%(1+ey/gcd_n)==0){
                ans++;
            }else{
                break;
            }
            long long y=ey/gcd_n,x=ex/(1+y);
            ex=x;
        }
        printf("Case #%d: %lld\n",rnd,ans);
        rnd++;
    }
    return 0;
}



此外,zhangjiatao1还用了dfs做,就是在没有发现起始位置和终止位置的gcd是一样的情况下如何解题。哪日补上这个做法。。。





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值