poj1753 Flip Game dfs 枚举 待补完 位运算

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41219 Accepted: 17896

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source


无限wa流。。。

这题出的真好啊。。。。。

每次感觉自己明白dfs的时候都会遇到一题打脸题///

先贴一下错误的dfs过程:

void dfs(int r,int c,int ans){
    if(ans == tot){
        if(judge()){
            flag = true;
        }
        return ;
    }
    if(r>4||c>4){
        return;
    }
    dfs(r+1, c, ans);
    dfs(r, c+1, ans);
    
    flip(r, c);
    
    dfs(r+1, c, ans+1);
    dfs(r, c+1, ans+1);
    
    flip(r, c);
    
}

找到了一个反例:

bbbb

bwwb

bwwb

bbbb

用这样的错误代码跑会输出impossible,为啥捏,我原先想象的很形象。。。一个格子是起点呗。。。翻不翻,然后想右走或者向下走。。。

为啥是错的呢,其实脑子里跑一遍这个过程就明白了,先一口气走到第一列最后一排,然后走不了了返回,接着在第三排走到了最后一列。。。。。

反正并不能每个格子都check!!

所以还是自己傻啊啊啊啊啊


关于这题,首先要确定下来能在16个操作之内能能解决。每个格子(当然也包括它周围的格子)呢,它翻奇数次就相当于翻一次,而翻偶数次则相当于不翻,因此只要确定这个格子到底翻不翻就行了

所以枚举翻格子次数进行爆搜。。。

搜。。。。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <sstream>
#include <queue>
using namespace std;
const int maxn = 10;
bool board[maxn][maxn];
int dx[4] = {1,-1,0,0};
int dy[4] = {0,0,1,-1};
bool judge(){
    int i,j;
    for(i=1;i<=4;i++){
        for(j=1;j<=4;j++){
            if(board[i][j]!=board[1][1]){
                return false;
            }
        }
    }
    return true;
}
int tot;
void flip(int r,int c){
    int i;
    board[r][c] = !board[r][c];
    for(i=0;i<4;i++){
        board[r+dx[i]][c+dy[i]] = !board[r+dx[i]][c+dy[i]];
    }
}
void print(int ans){
    int i,j;
    cout<<"ans: "<<ans<<endl;
    for(i=1;i<=4;i++){
        for(j=1;j<=4;j++){
            cout<<board[i][j];
        }
        cout<<endl;
    }
    cout<<"\n\n";
}
bool flag;
void dfs(int r,int c,int ans){
    //cout<<r<<" "<<c<<" "<<board[r][c]<<endl;
    //cout<<"a";
    //print(ans);
    if(ans == tot){
        if(judge()){
            flag = true;
        }
        return ;
    }
    if(r>4||flag){
        return;
    }
    
    flip(r, c);
    if(c<4){
        dfs(r, c+1, ans+1);
    }else{
        dfs(r+1, 1, ans+1);
    }
    flip(r, c);
    if(c<4){
        dfs(r, c+1, ans);
    }else{
        dfs(r+1, 1, ans);
    }
    return;
}
int main(){
    int i,j;
    char unit;
    for(i=1;i<=4;i++){
        for(j=1;j<=4;j++){
            cin>>unit;
            if(unit=='b'){
                board[i][j] = true;
            }else{
                board[i][j] = false;
            }
        }
    }
    flag = false;
    for(i=0;i<=16;i++){
        tot = i;
        dfs(1, 1, 0);
        if(flag){
            break;
        }
    }
    if(!flag){
        cout<<"Impossible\n";
    }else{
        cout<<i<<endl;
    }
    
    return 0;
}



这题还能用位运算搜索来做(每一个点用01来表示状态),哪日补上好了


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值