poj2485 Highways 最小生成树求最大边

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29525 Accepted: 13440

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU
题目会把这张图的邻接矩阵给我们,题意要求我们求的是最小生成树的最大边是多少,直接套模版上,Kruskal、Prime都可以

#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
const int maxn = 510;
int n,m;
long long maxE;
int father[maxn];
struct unit {
    int from,to;
    long long cost;
}save[maxn*maxn];
bool compare(unit a,unit b){
    return a.cost<b.cost;
}
int find(int x){
    if(x==father[x]) return x;
    return father[x] = find(father[x]);
}
bool isConnected(int a,int b){
    return find(a) == find(b);
}
void mix(int a,int b){
    int u = find(a),v = find(b);
    if(u==v){
        return ;
    }
    father[u] = v;
}
long long Kruskal(){
    long long result = 0;
    sort(save+1, save+1+m, compare);
    for(int i =1 ;i<=m;i++){
        if(isConnected(save[i].from, save[i].to)){
            continue;
        }
        mix(save[i].from, save[i].to);
        result += save[i].cost;
        maxE = max(maxE,save[i].cost);
    }
    return result;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int i,j;
        for(i=1;i<=n;i++){
            father[i]=i;
        }
        /*for(i=1;i<=m;i++){
            scanf("%d%d%lld",&save[i].from,&save[i].to,&save[i].cost);
        }*/
        int a;
        m = 0;
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++){
                scanf("%d",&a);
                save[++m].from = i;
                save[m].to = j;
                save[m].cost = a;
            }
        }
        maxE = 0;
        bool flag = true;
        long long result = Kruskal();
        printf("%lld\n",maxE);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值