POJ - 3104 Drying(二分最大化最小值)

点击打开题目链接

Drying
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 15802Accepted: 4015

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2
3

sample output #2
2

Source

Northeastern Europe 2005, Northern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]

二分答案。

①cin超时。

②long long

③特殊判断k为1

④a[i]低于二分时间的跳过,大于二分时间的求time。(time向上取整)

附上AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>

using namespace std;
const int maxn = 100000 + 5;
typedef long long ll;
ll n, t;
ll water[maxn];

bool judge(ll mid) {
	ll time = 0;
	for (ll i = 0; i < n; i++) {
		if (water[i] < mid) continue;
		else {
			time += (water[i] - mid + ( t - 2 )) / (t - 1);
			if (time > mid)return false;
		}
	}
	return true;//true:时间少于mid
}
int main() {
	scanf("%lld", &n);
	ll maxd = 0;
	for (ll i = 0; i < n; i++) {
		scanf("%lld", &water[i]);
		maxd = max(maxd, water[i]);
	}
	scanf("%lld", &t);
	if (t == 1) {
		cout << maxd << endl;
	}
	else {
		ll l = 0, r = maxd, mid;
		while (r - l > 1) {
			mid = (r + l) / 2;
			if (judge(mid)) {
				r = mid;
			}
			else l = mid;
		}
		cout << r << endl;
	}
	
	//	system("pause");
	return 0;
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值