How many(字符串最小表示法)

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3451    Accepted Submission(s): 1542


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
 
 
4 0110 1100 1001 0011 4 1010 0101 1000 0001
 

Sample Output
 
 
1 2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<set>
using namespace std;
int len;
const int maxn = 10000 + 10;
char s[maxn];
char t[maxn];
set<string>st;
//字符串最小表示法 
int minRepresentation(char *s){
	int i=0,j=1,k=0;
	while(i<len && j<len && k<len){
		int tmp = s[(i + k)%len] - s[(j + k)%len];
		if(tmp == 0) k++; //相等
		else{
			if(tmp > 0)
				i += k+1; // i = i + k + 1;
			else
				j += k+1;
			if(i == j) j++;
			k = 0;
		}
	}
	return min(i,j);
}
void getSet(char *s){
	//cout<<s<<"*****************"<<endl; 
	s[len/2] = '\0';//字符串以'\0'结束, 
	//cout<<s<<"............"<<endl; 
	st.insert(s);
}
int main(){
	int n;
	while(scanf("%d",&n)!=EOF ){
		st.clear();
		for(int i=0;i<n;i++){
			scanf("%s",t);
			strcpy(s,t); //因为最后还要获得最小表示的串,所以这里将两个串合并,最后在len/2的位置处加上'\0'即可
			strcat(s,t);
			len = strlen(s);
			int k = minRepresentation(s);
		//	cout<<k<<",,,,,,"; 
			getSet(s+k);
		}
		cout<<st.size()<<endl;
//		set<string>:: iterator iter = st.begin();
//		while(iter!=st.end()){
//			cout<<*iter<<endl;
//			iter++;
//		} 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值