iOS开发之ruby与gem基本命令

转载 2016年06月01日 23:24:39
ruby -v #查看ruby 版本

ruby -e ''require"watir"; puts Watir::IE::VERSION'' #查看watir版本

gem -v #gem版本

gem update #更新所有包

gem update --system #更新RubyGems软件

gem install rake #安装rake,从本地或远程服务器

gem install rake --remote #安装rake,从远程服务器

gem install watir -v(或者--version) 1.6.2#指定安装版本的

gem uninstall rake #卸载rake包

gem list d #列出本地以d打头的

gem query -n ''[0-9]'' --local #查找本地含有数字的包

gem search log --both #从本地和远程服务器上查找含有log字符串的包

gem search log --remoter #只从远程服务器上查找含有log字符串的包

gem search -r log #只从远程服务器上查找含有log字符串的包

gem help #提醒式的帮助

gem help install #列出install命令 帮助

gem help examples #列出gem命令使用一些例子

gem build rake.gemspec #把rake.gemspec编译成rake.gem

gem check -v pkg/rake-0.4.0.gem #检测rake是否有效

gem cleanup #清除所有包旧版本,保留最新版本

gem contents rake #显示rake包中所包含的文件

gem dependency rails -v 0.10.1 #列出与rails相互依赖的包

gem environment #查看gem的环境

iOS开发中如何管理多个版本的Cocoapods、gem

需求场景 之前在集成集团的各种pod库时,发现如果不使用0.35.0版本的Cocoapods,就无法成功集成,所以无奈将自己机器上刚安装的最新版Cocoapods降级。可是好景不长,过了些许日子后,...

RubyGems简介和使用 ruby+gem常用命令

RubyGems是一个方便而强大的Ruby程序包管理器( package manager),类似RedHat的RPM.它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。无需安装,最新的Ru...

mac下升级ruby环境版本

mac下升级ruby环境版本在ios开发中会经常使用到cocoapods来管理第三方框架,在安装cocoapods的时候会涉及到ruby环境,有时候会因为版本过低会导致安装失败,本文主要讲一下如何升级...

解决CocoaPods各种慢的方案(gem换源+pod repo换源)

本文重点讲述如何对Cocoapods进行换源,解决由于github服务器慢带来的各种install慢update慢问题,亲测有效。...

Ruby学习笔记之gem 命令详解

Ruby学习笔记之gem 命令详解ruby -v #查看ruby 版本 ruby -e ''require"watir"; puts Watir::IE::VERSION'' #查看watir版本 r...

关于IOS新手在安装cocoa pods失败,因为ruby版本过低的解决方法+ (void) {升级ruby}

关于IOS新手在安装cocoa pods失败,因为ruby版本过低的解决方法+ (void) {升级ruby}

做iOS开发我为什么弃用Objective-C而选择RubyMotion?

Hendrik Mans是德国汉堡市的一名程序员,他从事iOS开发已有很长一段时间了,起初他一直使用Objective-C语言进行编程而忽视了RubyMotion。从前他认为 RubyMotion只是...

升级ios10默认ruby版本

公司IOS编译机是IOS10.11.5系统,默认ruby为2.0.0 因cocoapods高版本需要ruby>=2.2.2,所以需要对原有ruby进行升级或重新通过rvm安装。 但通过rvm安装的ru...

iOS开发 -终端更新Ruby步骤和遇见奇葩问题的解决办法

今天安装cocoapods时候出现了下面的提示 Error installing pods:active support requires Ruby version >= 2.2.0 这个需求...

cocoapods:安装以及更新Ruby环境教程

今天换了一台新的mac 在使用的时候发现cocoapods不可以使用 安装cocoapods的时候提示这个错误 ERROR: Error installing cocoapods: active...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:iOS开发之ruby与gem基本命令
举报原因:
原因补充:

(最多只允许输入30个字)