Centos(linux) 简单方法升级php到php5.2.6 mysql5.1.58

原创 2012年03月28日 09:20:19

Centos系统软件仓中的php没有更新还是保持了5.1.6

如果不想手动编译php,但是官方的yum源里面没有

所以要手动添加一个源

 

添加一个额外的源:

 rpm –import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

vi /etc/yum.repos.d/utterramblings.repo

(如果没有这个文件新加上)

在打开的文件中加入以下内容:

[utterramblings]

name=Jason’s Utter Ramblings Repo

baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/

enabled=1

gpgcheck=1

gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

保存

 

 yum update php

Loading “fastestmirror” plugin

Loading mirror speeds from cached hostfile

* utterramblings: www.jasonlitka.com

* base: centos.candishosting.com.cn

* updates: ftp.hostrino.com

* addons: ftp.hostrino.com

* extras: ftp.hostrino.com

utterramblings 100%|=========================| 951 B 00:00

primary.xml.gz 100%|=========================| 68 kB 00:02

utterrambl:################################################## 230/230

Setting up Update Process

Resolving Dependencies

> Running transaction check

> Package php.i386 0:5.2.6-jason.1 set to be updated

> Processing Dependency: php-common = 5.2.6-jason.1 for package:php

> Processing Dependency: php-cli = 5.2.6-jason.1 for package: php

> Running transaction check

> Package php-cli.i386 0:5.2.6-jason.1 set to be updated

> Package php-common.i386 0:5.2.6-jason.1 set to be updated

> Processing Dependency: php-common = 5.1.6-20.el5_2.1 forpackage: php-gd

> Processing Dependency: php-common = 5.1.6-20.el5_2.1 forpackage: php-ldap

> Processing Dependency: php-common = 5.1.6-20.el5_2.1 forpackage: php-pdo

> Processing Dependency: php-common = 5.1.6-20.el5_2.1 forpackage: php-mysql

> Processing Dependency: php-common = 5.1.6-20.el5_2.1 forpackage: php-mbstring

> Processing Dependency: php-common = 5.1.6-20.el5_2.1 forpackage: php-xml

> Running transaction check

> Package php-mysql.i386 0:5.2.6-jason.1 set to be updated

> Package php-mbstring.i386 0:5.2.6-jason.1 set to be updated

> Package php-ldap.i386 0:5.2.6-jason.1 set to be updated

> Package php-gd.i386 0:5.2.6-jason.1 set to be updated

> Package php-xml.i386 0:5.2.6-jason.1 set to be updated

> Package php-pdo.i386 0:5.2.6-jason.1 set to be updated

> Finished Dependency Resolution

 

Dependencies Resolved

 

=============================================================================

Package Arch Version Repository Size

=============================================================================

Updating:

php i386 5.2.6-jason.1 utterramblings 3.7 M

php-cli i386 5.2.6-jason.1 utterramblings2.6 M

php-common i386 5.2.6-jason.1utterramblings 481 k

Updating for dependencies:

php-gd i386 5.2.6-jason.1 utterramblings320 k

php-ldap i386 5.2.6-jason.1 utterramblings56 k

php-mbstring i386 5.2.6-jason.1utterramblings 1.3 M

php-mysql i386 5.2.6-jason.1 utterramblings258 k

php-pdo i386 5.2.6-jason.1 utterramblings159 k

php-xml i386 5.2.6-jason.1 utterramblings316 k

 

Transaction Summary

=============================================================================

Install 0 Package(s)

Update 9 Package(s)

Remove 0 Package(s)

 

Total download size: 9.1 M

Is this ok [y/N]: y

Downloading Packages:

(1/9): php-5.2.6-jason.1. 100%|=========================| 3.7 MB 02:35

(2/9): php-pdo-5.2.6-jaso 100%|=========================| 159 kB 00:05

(3/9): php-common-5.2.6-j 100%|=========================| 481 kB 00:15

(4/9): php-xml-5.2.6-jaso 100%|=========================| 316 kB 00:06

(5/9): php-cli-5.2.6-jaso 100%|=========================| 2.6 MB 01:36

(6/9): php-gd-5.2.6-jason 100%|=========================| 320 kB 00:10

(7/9): php-ldap-5.2.6-jas 100%|=========================| 56 kB 00:03

(8/9): php-mbstring-5.2.6 100%|=========================| 1.3 MB 00:41

(9/9): php-mysql-5.2.6-ja 100% |=========================|258 kB 00:06

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

Updating : php-common####################### [ 1/18]

Updating : php-pdo #######################[ 2/18]

Updating : php-cli #######################[ 3/18]

Updating : php-mysql####################### [ 4/18]

Updating : php-mbstring####################### [ 5/18]

Updating : php-ldap #######################[ 6/18]

Updating : php-gd ####################### [7/18]

Updating : php-xml #######################[ 8/18]

Updating : php ####################### [9/18]

Cleanup : php-mysql #######################[10/18]

Cleanup : php-mbstring####################### [11/18]

Cleanup : php-ldap ####################### [12/18]

Cleanup : php-gd #######################[13/18]

Cleanup : php-cli #######################[14/18]

Cleanup : php-xml #######################[15/18]

Cleanup : php-common####################### [16/18]

Cleanup : php-pdo #######################[17/18]

Cleanup : php #######################[18/18]

 

Updated: php.i386 0:5.2.6-jason.1php-cli.i386 0:5.2.6-jason.1 php-common.i386 0:5.2.6-jason.1

Dependency Updated: php-gd.i3860:5.2.6-jason.1 php-ldap.i386 0:5.2.6-jason.1 php-mbstring.i386 0:5.2.6-jason.1php-mysql.i386 0:5.2.6-jason.1 php-pdo.i386 0:5.2.6-jason.1 php-xml.i3860:5.2.6-jason.1

Complete!

service httpd restart

停止httpd[确定]

启动httpdhttpd: Could not reliably determine the servers fullyqualified domain name, using localhost.localdomain for ServerName

[确定]

 rpm -q php


Centos(linux) 简单方法升级php到php5.2.6

装完Centos5.2 看了看php版本才5.1.6,于是下意识的 # yum update php Loading “fastestmirror” plugin Existing lock /...
  • ahstudy
  • ahstudy
  • 2011年11月04日 11:52
  • 347

centos6.5的php5.3.3这个版本怎么升级到5.6

https://zhidao.baidu.com/question/1050957630272706259.html 简单介绍一下,如何在CentOS上安装PHP5.6。 配置yum源 ...
  • Strenghthen
  • Strenghthen
  • 2017年01月11日 00:14
  • 1597

centos之php5.3升级到php5.4步骤

yum配置 执行命令下载、安装yum源: # wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rp...
  • e421083458
  • e421083458
  • 2015年06月02日 11:16
  • 7506

centos下升级php5.3到php5.6

查看并删除原有的php5.3查看原有的php版本:php -V 查看已经安装的php的包:yum list installed | grep php 可以看到如下原有的安装包:php-common.x...
  • na_beginning
  • na_beginning
  • 2016年11月30日 21:32
  • 11518

CentOS从php5.3升级到php5.5

一:首先检查php版本 php --version 二:增加 yum repository 以便下载php rpm -Uvh http://mirror.webtatic.co...
  • qq_26891045
  • qq_26891045
  • 2016年04月22日 20:41
  • 956

centos6下php53升级为php7

1、查看版本[root@web-1 blog]# php -v No log handling enabled - turning on stderr logging Created director...
  • fanren224
  • fanren224
  • 2017年05月09日 16:52
  • 1130

Centos下PHP5升级PHP7

首先下载PHP7安装包,使用wget http://am1.php.net/distributions/php-7.2.0.tar.bz2,或者直接访问下载,然后ftp到linux服务器 解压压缩包...
  • u013521188
  • u013521188
  • 2017年12月22日 10:35
  • 314

Centos6.5下进行PHP版本升级

统计插件WP Statistics要求PHP5.4以上,可本机PHP为5.3.3,无奈只有对服务器PHP进行升级,遂写下本文。...
  • aliveqf
  • aliveqf
  • 2017年04月22日 15:23
  • 1463

CentOS6.5在已有低版本环境下安装升级Apache+MySQL+PHP

由于最近工作中遇到了一个在比较老旧RedHat系Linux发行版系统上升级安装Apahce+MySQL+PHP环境的事情,鼓弄了半天,发现和在比较新的操作系统如CentOS7上安装配置还是有一定区别的...
  • xreztento
  • xreztento
  • 2016年12月16日 16:58
  • 2450

centos yum升级php5.3.3到最5.6.3

不要轻易升级,否则后果很严重! 注意事项: 1 升级后之前的php扩展不会丢失 自动会安装对应最新php的扩展 2 升级后需重启下apache 才能看到 3 升级时候会提示 Loaded pl...
  • nuli888
  • nuli888
  • 2016年07月09日 10:03
  • 11413
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Centos(linux) 简单方法升级php到php5.2.6 mysql5.1.58
举报原因:
原因补充:

(最多只允许输入30个字)