关闭

zabbix 邮件报错 Support for SMTP authentication was not compiled in

标签: smtpcentos邮件zabbix
2195人阅读 评论(2) 收藏 举报
分类:

服务器系统是centos6.5
zabbix版本是3.0.4
根据 网上教程配置好邮件脚本后,触发发送邮件的时候报错:

Support for SMTP authentication was not compiled in 

官网说的是

To make SMTP authentication options available, Zabbix server should be
compiled with the –with-libcurl compilation option with cURL 7.20.0
or higher.

大概意思是说需要curl版本最低7.20.0,然后查看下自己的版本号

curl -V

发现是7.19

于是更新版本:

1.创建一个新文件 /etc/yum.repos.d/city-fan.repo
2.复制下面的到上面文件中:

[CityFan]
name=City Fan Repo
baseurl=http://www.city-fan.org/ftp/contrib/yum-repo/rhel5/x86_64/
enabled=1
gpgcheck=0

3.更新安装

yum clean all
yum install curl 

查看是否更新成功:

curl -V

输出:

curl 7.50.1 //更新成功

接下来重新编译安装一次zabbix,具体编译安装跟之前一样。

如果编译过程中出现

libcurl library not found

可能有多种原因,可以参考我的解决方法是查看/usr/bin/curl-config文件版本号是否跟当前安装版本号一致,我用的笨方法直接去官方下载安装版本(我这是7.50.1)的包:

curl-7.50.1.tar.gz

解压后把里面的curl-config 替换掉 /usr/bin/ 的 curl-config文件,然后重新编译,成功

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:100297次
    • 积分:1340
    • 等级:
    • 排名:千里之外
    • 原创:24篇
    • 转载:48篇
    • 译文:2篇
    • 评论:8条
    文章分类
    最新评论