kaldi 一些错误

原创 2016年05月30日 15:07:34

1)“awk:line12:function gensub never defined

       解决: sudo apt-get install gawk


2)“Error: and run extras/install_irstlm.sh”

      怎么回事呢?因为这个例程建立语言模型是用irstlm工具建立的,但是在最新版本的kaldi里面,irstlm不是默认编译的。首先进入kaldi目录下的tools/extras目录,执行install_irstlm.sh脚本。安装完成以后,  目录下出现irstlim目录。由于timit例程里面的引用irstlm工具的路径是tools目录,所以把这个目录拷贝到tools/目录下。回到egs/timit/s5目录,执行./run.sh脚本,于是timit例程就跑起来了。


3)Error: the IRSTLM is not available or compiled

    解决:cd kaldi-master/tools/extras

          ./install_irstlm.sh

          将生成的env.sh复制到tools文件夹下即可。

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

kaldi学习笔记:run.sh(egs/timit/s5)详细分析:从数据准备到特征提取

首先看一下前三行: . ./cmd.sh [ -f path.sh ] && . ./path.sh set -e(1)cmd.sh脚本文件包含三部分内容:# "queue.pl" uses qsu...

Kaldi学习手记(一):Kaldi的编译安装

Kaldi是一款基于C++编写的开源语音识别工具箱。这款工具既可以在Windows下编译也可以在Linux下编译。不过听学姐说以后还是在Linux下做开发多一些,我就想干脆顺便把Linux环境熟悉熟悉...

kaldi 跑数据过程中遇到的错误

. /run.sh: you need to define options for your cluster. 这个问题是没有注释掉s5中cmd.sh中的a)、b)两项,c)选项是在不含有GPU的主机...

kaldi上运行thchs30中文语音库的错误总结

运行中文库thchs30时遇到的错误
  • sut_wj
  • sut_wj
  • 2017-05-14 15:26
  • 1082

Kaldi三音素GMM学习笔记

  • 2017-04-13 20:34
  • 1.35MB
  • 下载

Kaldi学习笔记:跑Aurora语料库

1、Aurora语料库 跟tidigits有点类似,说话的内容也是1-9ZO,test有1000条数据,train有8000多条数据。在Kaldi中没有Aurora的样例,可以在tidigits的样...

kaldi学习资料

  • 2015-11-12 12:58
  • 3.35MB
  • 下载

kaldi学习笔记 -- 构造语言模型相关脚本 -- ami_train_lms.sh,utils/format_lm.sh

本文主要讲解kaldi语言模型构造脚本中关键指令的作用,输入和输出。
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)