ZOJ 2588 Burning Bridges(求含重边的无向连通图的割边) - from lanshui_Yang

Burning Bridges

Time Limit: 5 Seconds Memory Limit: 32768 KB

Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?


Input

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.


Output

On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.

Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.


Sample Input

2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

Sample Output

2
3 7

1
4
     题目大意:直接把题目抽象一下吧,给你一个无向连通图,每两个顶点之间可能有多条边(即含重边),让你求出图中割边(即桥)的个数,并输出割边的序号。
     解题思路:这是一道典型的求连通图割边的问题,需要注意的是,此图可能有重边。
     割边的求法:割边的求解过程与求关节点的过程类似,判断方法是:无向图中的一条边(u,v)是桥,当且仅当(u,v)为深度优先搜索生成树中的边。且满足dfn[n] < low[v] 。
     Ps:ZOJ判题很严格,笔者PE了无数次,才发现一个小小的坑,具体请看程序。
     代码如下:
#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdio>
#include<vector>
#include<set>
#include<algorithm>
using namespace std ;
const int MAXN = 10005 ;
struct Node
{
    int adj ;
    int e ;
    Node *next ;
} ;
Node *vert[MAXN] ; // 顶点指针数组
bool vis[MAXN] ;  // 标记数组,判断顶点是否被访问
bool vise[111111] ; // 标记数组,判断边是否被访问
set <int> bridges ;  // 记录割边的集合
int low[MAXN] ;
int dfn[MAXN] ;
int tmpdfn ;
int tmpe ;
int n , m ;
int root ;  // 根节点
bool first = true ;
void init()
{
    scanf("%d%d" , &n , &m) ;
    memset(vert , 0 , sizeof(vert)) ;
    bridges.clear() ;
    int i ;
    tmpe = 0 ;
    for(i = 1 ; i <= m ; i ++)
    {
        int a , b ;
        scanf("%d%d" , &a , &b) ;
        Node * p ;
        p = new Node ;
        p -> adj = b ;
        p -> e = ++ tmpe ;
        p -> next = vert[a] ;
        vert[a] = p ;

        p = new Node ;
        p -> adj = a ;
        p -> e = tmpe ;
        p -> next = vert[b] ;
        vert[b] = p ;
        root = a ;
    }
}
void dfs(int u)
{
    Node *p = vert[u] ;
    while (p != NULL)
    {
        int v = p -> adj ;
        int te = p -> e ;
        if(!vise[te])  // 注意:因为此题中可能有重边,所以应先判重,即访问过的边就不再访问
        {
            vise[te] = 1 ;
            if(!vis[v])
            {
                vis[v] = 1 ;
                dfn[v] = low[v] = ++ tmpdfn ;
                dfs(v) ;
                low[u] = min(low[u] , low[v]) ;
                if(low[v] > dfn[u])  // 注意此处是严格的 “ > ”
                {
                    bridges.insert(te) ;
                }
            }
            else
            {
                low[u] = min(low[u] , dfn[v]) ;
            }
        }
        p = p -> next ;
    }
}
void solve()
{
    if(first) first = false ;
    else puts("") ;
    memset(dfn , 0 , sizeof(dfn)) ;
    memset(vis , 0 , sizeof(vis)) ;
    memset(low , 0 , sizeof(low)) ;
    memset(vise , 0 ,sizeof(vise)) ;
    tmpdfn = 1 ;
    dfn[root] = low[root] = tmpdfn ;
    vis[root] = 1 ;
    dfs(root) ;
    cout << bridges.size() << endl ;
    set<int> :: iterator it ;
    int cnt = 0 ;
    for(it = bridges.begin() ; it != bridges.end() ; ++ it)
    {
        printf("%d" , *it) ;
        if( cnt < bridges.size() - 1)
            printf(" ") ;
        cnt ++ ;
    }
    if(bridges.size() > 0)  // 注意:此处极易PE,想想bridges.size() == 0 的情况
    puts("") ;
}
void dele()
{
    int i ;
    for(i = 1 ; i <= n ; i ++)
    {
        Node *p = vert[i] ;
        while (p != NULL)
        {
            vert[i] = p -> next ;
            delete p ;
            p = vert[i] ;
        }
    }
}
int main()
{
    int T ;
    scanf("%d" , &T) ;
    first = true ;
    while (T --)
    {
        init() ;
        solve() ;
        dele() ;
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值