关闭

centos redHat 64位linux 安装iNode客户端

标签: yumcentos
1117人阅读 评论(0) 收藏 举报
分类:

64位centos/redhat 安装inode上网客户端

下载linux安装包:http://download.csdn.net/detail/le119126/9287189

切换到root账户安装

解压后

./install.sh    //安装

./iNodeClient   //以root身份运行

1.出现某个文件 Permission denied

如 iNodeMon

chmod 755 iNodeMon,添加运行权限

2.出现各种库没有找不到:

一般哪个库找不到就 直接命令: yum install 库名

a.libgtk-x11-2.0.so

其实系统已经安装64位的,但是没有32位的,所以还得安装

[root@localhost iNodeClient]# yum whatprovides libgtk-x11-2.0.so.0 // 查看 libgtk-x11-2.0.so.0 库属于哪个包

然后安装那个包,也可以直接

yum install libgtk-x11-2.0.so.0 --setopt=protected_multilib=false

已经装了64再装32位 会出现 Protected multilib versions 错误,无法安装,所以 在yum命令后面加入忽略参数:--setopt=protected_multilib=false

b.libpangox-1.0.so.0

这个库的包找不到,它需要下载安装pangox-compat-0.0.2-2.el7.i686.rpm

c.libtiff.so.3: wrong ELF class: ELFCLASS64

这是说/usr/lib/ 下面的库是64位,用 yum install compat-libtiff3-3.9.4-11.el7.i686在装一此32位的

3,配置

root身份./iNodeClient  运行,第一次需要配置

主要是  Select NIC  要选择 enp9s0

Packet type  选择  Uincast


centos_Error: Protected multilib versions_解决方法

Error:  Multilib version problems found. This often means that the root

       cause is something else and multilib version checking is just

       pointing out that there is a problem. Eg.:

       

         1. You have an upgrade for glibc which is missing some

            dependency that another package requires. Yum is trying to

            solve this by installing an older version of glibc of the

            different architecture. If you exclude the bad architecture

            yum will tell you what the root cause is (which package

            requires what). You can try redoing the upgrade with

            --exclude glibc.otherarch ... this should give you an error

            message showing the root cause of the problem.

       

         2. You have multiple architectures of glibc installed, but

            yum can only see an upgrade for one of those arcitectures.

            If you don't want/need both architectures anymore then you

            can remove the one with the missing update and everything

            will work.

       

         3. You have duplicate versions of glibc installed already.

            You can use "yum check" to get yum show these errors.

       

       ...you can also use --setopt=protected_multilib=false to remove

       this checking, however this is almost never the correct thing to

       do as something else is very likely to go wrong (often causing

       much more problems).

       

       Protected multilib versions: glibc-2.12-1.107.el6_4.2.i686 != glibc-2.12-1.47.el6.x86_64

Error: Protected multilib versions: nss-softokn-freebl-3.14.3-3.el6_4.i686 != nss-softokn-freebl-3.12.9-11.el6.x86_64

 You could try using --skip-broken to work around the problem

** Found 111 pre-existing rpmdb problem(s), 'yum check' output follows:

SDL-1.2.14-3.el6.x86_64 is a duplicate with SDL-1.2.14-2.el6.x86_64

atlas-3.8.4-2.el6.x86_64 is a duplicate with atlas-3.8.4-1.el6.x86_64

audit-libs-2.2-2.el6.x86_64 is a duplicate with audit-libs-2.1.3-3.el6.x86_64

augeas-libs-0.9.0-4.el6.x86_64 is a duplicate with augeas-libs-0.9.0-1.el6.x86_64

bash-4.1.2-15.el6_4.x86_64 is a duplicate with bash-4.1.2-8.el6.centos.x86_64

boost-date-time-1.41.0-17.el6_4.x86_64 is a duplicate with boost-date-time-1.41.0-11.el6_1.2.x86_64

 

错误的解决方法(很多就在提示里面):

#1 手动处理重复

  这个是要死人的

#2 删除重复的

  这个有时候会导致已经编译和安装的软件出问题,所以还是要有心理准备

#3 自动删除重复命令

  package-cleanup --cleandupes

 这个也会导致#2 的问题

#4 在yum命令后面加入忽略参数:--setopt=protected_multilib=false

you can also use --setopt=protected_multilib=false to remove

       this checking, however this is almost never the correct thing to

       do as something else is very likely to go wrong (often causing

       much more problems).

这里说了,很可能导致more probems。不过么,现实中,可以试试看,尤其是保持一个老系统照旧运行时,这个方法会起作用的
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:124479次
    • 积分:2865
    • 等级:
    • 排名:第12950名
    • 原创:154篇
    • 转载:115篇
    • 译文:0篇
    • 评论:2条
    最新评论