hdoj 1171 Big Event in HDU <母函数变形>

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35148    Accepted Submission(s): 12188


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

Author
lcy
 




代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MA 150000
int m[MA],kp;
int shu[MA],nn;
int main()
{
    int n,v,f;
    while (scanf("%d",&n),n>=0)
    {
        int s=0,es;nn=0;
        for (int i=0;i<n;i++)
        {
            scanf("%d%d",&v,&f);
            s+=v*f;
            while (f--)
            {
                shu[nn++]=v;
            }
        }
        kp=0;es=s/2;
        memset(m,0,sizeof(m));
        int qu[MA];
        qu[kp++]=0;m[0]=1;
        int a,b,c;
        for (int i=0;i<nn;i++)
        {
            int ll=kp;
            for (int j=0;j<ll;j++)
            {
                c=qu[j]+shu[i];

                if (c>es)
                    continue;
                if (!m[c])
                {
                    qu[kp++]=c;
                    m[c]=1;
                }
            }
        }
        int ss;
        for (int i=es;i>=0;i--)
        if (m[i])
        {
            ss=i;
            break;
        }
        printf("%d %d\n",s-ss,ss);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值