How to install QEMU under FreeBSD 8.1 as host

QEMU is a processor emulator that relies on dynamic binary translation to achieve a reasonable speed while being easy to port on new host CPU architectures.
When used as a machine emulator, QEMU can run Operating Systems and programs made for one machine on a different machine. By using dynamic translation, it achieves very good performance.
When used as a virtualizer, QEMU achieves near native performances by executing the guest code directly on the host CPU.

1. Install QEMU

To install QEMU under FreeBSD, enter:

 

# make install clean -C /usr/ports/emulators/qemu

 

Install QEMU with options showed in the following image:

Edit /boot/loader.conf to load required kernel modules at start up.
Add the following lines to /boot/loader.conf:
aio_load="YES"
kqemu_load="YES"

To load the kernel modules, enter:

kldload aio
kldload kqemu
2. Create QEMU Operating System as Guest

To create QEMU image for the new operating system, enter:

qemu-img create -f qcow2 ~/qemu/newos.img 8G
To install the new operating system, enter:
qemu -boot d -hda ~/qemu/newos.img -m 128 -cdrom ~/qemu/osimage.iso -localtime
Note: If you have any problems while installing the guest operating system then unload kqemu kernel module and install again, then after install, load the kqemu module again:
kldunload kqemu
qemu -boot d -hda ~/qemu/newos.img -m 256 -cdrom ~/qemu/osimage.iso -localtime
kldload kqemu
3. QEMU Usage

Typical usage of operating system under QEMU:

qemu -hda ~/qemu/newos.img -m 256 -localtime
Typical usage of operating system under QEMU in Snapshot mode:
qemu -hda ~/qemu/newos.img -m 256 -localtime -snapshot
Note: To commit made changes hit left_CTRL+left_ALT+2 and type commit.

To switch focus between QEMU mouse focus and X11 mouse focus use left_CTRL+left_ALT

To ensure that You use kqemu kernel module in user mode hit left_CTRL+left_ALT+2 and type info kqemu, if everything is fine you will see:
kqemu support: enabled for user code

To switch between QEMU console and QEMU opearating system emulation use left_CTRL+left_ALT+2 to go to console and left_CTRL+left_ALT+1 to back to emulation.

To enable network on emulated operating system, use DHCP configuration inside the emulated operating system to get automatic IP address 10.x.x.x.

After you quit the emulated operating system, use this command to launch again your emulated operating system:

qemu -hda ~/qemu/newos.img -m 256 -localtime
To have sound in the QEMU operating system, you just need to launch QEMU with -soundhw sb16 or -soundhw es1370 to emulate Sound Blaster 16, or Sound Blaster 128. You can also enable standart annoying BEEP with - soundhw pcspk. You can also enable all three of them:
qemu -hda ~/qemu/newos.img -m 256 -localtime -soundhw es1370,pcspk,sb16
Type qemu --help and qemu-img --help for more options.
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值