PAT(甲级)1084

1084. Broken Keyboard (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI

#include <cstdio>

int main()
{
	char str1[100];
	char str2[100];
	bool brokenkeys[40];
	char output[40];
	int i,j=0;
	for(i=0;i<40;i++)
	    brokenkeys[i] = false;
	scanf("%s%s",str1,str2);
	char *p1=str1;
	char *p2=str2;
	while(*p1 !='\0'){
		if(*p1 != *p2){    //it does not matter if p2 comes to its end
			if(*p1>='0'&&*p1<='9'&&!brokenkeys[*p1-'0']){
				brokenkeys[*p1-'0']=true;;
				output[j++]=*p1;
			}
			else if(*p1>='a'&&*p1<='z'&&!brokenkeys[10+*p1-'a']){
				brokenkeys[10+*p1-'a']=true;
				output[j++] = *p1-'a'+'A';
			}
			else if(*p1>='A'&&*p1<='Z'&&!brokenkeys[10+*p1-'A']){
				brokenkeys[10+*p1-'A'] = true;
				output[j++] = *p1;				
	       }
			else if(*p1=='_'&&!brokenkeys[36]){
				brokenkeys[36] = true;
				output[j++] = '_';
			}
		}else
			p2++;		    			
        p1++;
	}
    output[j] = '\0';
    printf("%s\n",output);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值