异或解题:Find the Lost Sock

I - Find the Lost Sock
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Alice bought a lot of pairs of socks yesterday. But when she went home, she found that she has lost one of them. Each sock has a name which contains exactly 7 charaters.

Alice wants to know which sock she has lost. Maybe you can help her.

Input

There are multiple cases. The first line containing an integer n (1 <=n <= 1000000) indicates that Alice bought n pairs of socks. For the following 2*n-1 lines, each line is a string with 7 charaters indicating the name of the socks that Alice took back.

Output

The name of the lost sock.

Sample Input

2
aabcdef
bzyxwvu
bzyxwvu
4
aqwerty
eas fgh
aqwerty
easdfgh
easdfgh
aqwerty
aqwerty
2
0x0abcd
0ABCDEF
0x0abcd

Sample Output

aabcdef
eas fgh
0ABCDEF
Hint

Because of HUGE input, scanf is recommended.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <cmath>

using namespace std;

int main(){
    int n;
    int i;
    int m, j;
    map <string ,int >mm;
    string str;
    char str1[1000];
    while(cin >> n){
        m = n * 2 - 1;
        getchar();
        scanf("%[^\n]", &str1);
        str = str1;
        for(i = 1; i < m; i ++){
            getchar();
            scanf("%[^\n]",&str1);
            for(j = 0; j < 7; j ++)
                str[j] ^= str1[j];
        }
        for(i = 0; i < 7; i ++)
            cout << str[i];
        cout << endl;
    }
    return 0;
}



此题也可用map来做,不过超时。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值