libstdc 包太新,导致无法安装 jdk

原创 2007年09月25日 15:44:00

 

 

今天安装 jdk 时出现如下错误

[root@localhost sftscr]# ./java_ee_sdk-5_03-linux.bin
./java_ee_sdk-5_03-linux.bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
[root@localhost sftscr]#

经检查,发现libstdc包如下:

[root@localhost ~]# ls /usr/lib/libstdc*
/usr/lib/libstdc++.so.5      /usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.5.0.7  /usr/lib/libstdc++.so.6.0.8
[root@localhost ~]# 

 于是下载 compat-libstdc++-33-3.2.3-47.3.i386.rpm

接着安装 rpm -ivh compat-libstdc++-33-3.2.3-47.3.i386.rpm

现安装 jdk, 一切问题解决.

64位ubuntu 14.04安装32位dr.com客户端教程(不用安装glibc.i686 libstdc++.i686)

64位的ubuntu没32位的运行库真是令人bei

Centos 6.4 下安装chrome提示 libstdc++.so.6问题的解决方案

Centos6.4 和 Redhat 7_64bit下安装chrome (或者别的版本的也会) 安装的时候提示 requires libstdc++.so.6(GLIBCXX_3.4.15) 比如...

CentOS 6.4(64位)上安装错误libstdc++.so.6(GLIBCXX_3.4.14)解决办法

CentOS 6.4(64位)上安装错误libstdc++.so.6(GLIBCXX_3.4.14)解决办法 (2013-07-29 13:18:01) 转载▼ 分类...
  • lqzixi
  • lqzixi
  • 2014年04月29日 20:47
  • 1284

bash shell脚本安装tcmalloc,linunwind,libstdc++ so库

因为项目中使用了tcmalloc,而是用gcc 5.2.0编译的64位代码,所以项目中的so依赖libunwind,tcmalloc,以及gcc5.2.0的libstdc++.so [roo@t2...
  • 10km
  • 10km
  • 2016年01月02日 10:42
  • 558

应为本机上的jdk版本低导致spring-tool-suite无法启动

前提: 编译器版本:spring-tool-suite-3.7.0.RELEASE-e4.5-win32-x86_64 本机jdk(环境变量配置):1.6 问题日志:!SESSION 2...

JDK1.5的32位和64位安装包

  • 2017年10月30日 14:09
  • 85.48MB
  • 下载

jdk1.6-1.8安装包

  • 2017年10月30日 11:22
  • 39B
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:libstdc 包太新,导致无法安装 jdk
举报原因:
原因补充:

(最多只允许输入30个字)