poj 2352 Stars(线段树||树状数组)

20 篇文章 0 订阅
7 篇文章 0 订阅
Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36881 Accepted: 16056

点击打开链接

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:

参照转自博客:点击打开链接

在坐标上有n个星星,如果某个星星坐标为(x, y), 它的左下位置为:(x0,y0),x0<=x 且y0<=y。如果左下位置有a个星星,就表示这个星星属于level x

按照y递增,如果y相同则x递增的顺序给出n个星星,求出所有level水平的数量。


分析与总结:

因为输入是按照按照y递增,如果y相同则x递增的顺序给出的, 所以,对于第i颗星星,它的level就是之前出现过的星星中,横坐标x小于等于i星横坐标的那些星星的总数量(前面的y一定比后面的y小)。

所以,需要找到一种数据结构来记录所有星星的x值,方便的求出所有值为0~x的星星总数量。

个人认为:

树状数组和线段树都是很适合处理这种问题,但是树状数组比较简单,一般的树状数组能做到的,线段树都能做到

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define MAX 33010
#define mid ((l+r)>>1)
#define lson l,mid,2*v
#define rson mid+1,r,2*v+1
int level[4*MAX];
int num[4*MAX];
int sum[4*MAX];

void build(int l,int r,int v)
{
	sum[v]=0;
	if(l==r)
	{
	 sum[v]=num[v];
	 return ;	
	}
    build(lson);
    build(rson);
    sum[v]=sum[2*v]+sum[2*v+1]; 
}

void update(int l,int r,int v,int pos,int x)
{
	if(l==r)
	{
		sum[v]+=x;
		return ;
	}
	if(pos<=mid)
	update(lson,pos,x);
	else
	update(rson,pos,x);
	sum[v]=sum[2*v]+sum[2*v+1];
}

int query(int l,int r,int v,int lpos,int rpos)
{
  if(lpos<=l&&rpos>=r)
  return sum[v];
  if(rpos<=mid)
  return query(lson,lpos,rpos);
  else if(lpos>mid)
  return query(rson,lpos,rpos);
  else
  return query(lson,lpos,mid)+query(rson,mid+1,rpos);
}

int main()
{
 int n;
 while(~scanf("%d",&n))
 {
  memset(sum,0,sizeof(sum));
  memset(num,0,sizeof(num));
  memset(level,0,sizeof(level));
  
  build(1,MAX,1);	
  for(int i=0;i<n;i++)
  {
    int x,y;
  	scanf("%d%d",&x,&y);
  	++x;
  	level[query(1,MAX,1,1,x)]++;
  	update(1,MAX,1,x,1);
  }
  for(int i=0;i<n;i++)
   printf("%d\n",level[i]);
 }	
 return 0;
} </span>
树状数组,用这个比较简单
<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define MAX 35010//注意数组 
int level[MAX];
int num[MAX];
int n;

int lowbit(int x)
{
	return x&(-x);
}
void update(int i,int x)
{
	while(i<MAX)
	{
		num[i]+=x;
		i+=lowbit(i);
	}
}
int query(int i)
{
	int sum=0;
	while(i>0) 
	{
		sum+=num[i];
		i-=lowbit(i);
	}
	return sum;
} 

int main()
{
 while(~scanf("%d",&n))
 {
  memset(num,0,sizeof(num));
  memset(level,0,sizeof(level));
  for(int i=1;i<=n;i++)
  {
  	int x,y;
  	scanf("%d%d",&x,&y);
  	level[query(x+1)]++;
  	update(x+1,1);
  }
  for(int i=0;i<n;i++)
   printf("%d\n",level[i]);
 }	
 return 0;
} </span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值