POJ1201 HDU1384 Intervals【SPFA】【差分约束】

Intervals
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 22307Accepted: 8413

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 

writes the answer to the standard output. 


Input
The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.


Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.


Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1


Sample Output

6


Source

Southwestern Europe 2002


题目大意:给你N个条件去构造一个集合,每个条件都是在区间[ai,bi]上最少有ci个数在集合内。

ci可在区间[ai,bi]中随意取,但是不能重复。问:构造这个集合最少包含几个点。

思路:差分约束思想。设Si为区间[0,i-1]的范围内点的个数,则S(bi) - S(ai-1) >= ci,即

S(ai-1) - S(bi) <= -ci。但是,之前Si表示的是[0,i-1]的范围内,要选多少个数,数列Si是递增的。

增量最大是1,即0 <= Si - Si-1 <= 1。即两个隐含约束条件S(i-1) - S(i) <= 0,S(i)-S(i-1) <= 1。

把这三种约束建边构建一个差分约束系统,用SPFA求最短路径。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN = 50050;
const int INF = 0xffffff0;

struct EdgeNode
{
    int to;
    int w;
    int next;
}Edges[MAXN << 2];
int Head[MAXN],Dist[MAXN],vis[MAXN];

int SPFA(int Left,int Right)
{
    for(int i = Left; i <= Right+1; ++i)
        Dist[i] = INF;
    memset(vis,0,sizeof(vis));
    queue<int> Q;
    Q.push(Right);
    vis[Right] = 1;
    Dist[Right] = 0;
    while( !Q.empty() )
    {
        int u = Q.front();
        Q.pop();
        vis[u] = 0;
        for(int i = Head[u]; i != -1; i = Edges[i].next)
        {
            int temp = Dist[u] + Edges[i].w;
            if( temp < Dist[Edges[i].to])
            {
                Dist[Edges[i].to] = temp;
                if( !vis[Edges[i].to] )
                {
                    vis[Edges[i].to] = 1;
                    Q.push(Edges[i].to);
                }
            }
        }
    }
    return -Dist[Left];
}

int main()
{
    int N,Left,Right,a,b,c;
    while(~scanf("%d",&N))
    {
        Left = MAXN,Right = 0;
        memset(Head,-1,sizeof(Head));
        memset(Edges,0,sizeof(Edges));
        int id = 0;
        for(int i = 0; i < N; ++i)
        {
            scanf("%d%d%d",&a,&b,&c);
            Edges[id].to = a;
            Edges[id].w = -c;
            Edges[id].next = Head[b+1];
            Head[b+1] = id++;
            if(a < Left)
                Left = a;
            if(b > Right)
                Right = b;
        }
        Right++;
        for(int i = Left; i < Right; ++i)
        {
            Edges[id].to = i;
            Edges[id].w = 0;
            Edges[id].next = Head[i+1];
            Head[i+1] = id++;

            Edges[id].to = i+1;
            Edges[id].w = 1;
            Edges[id].next = Head[i];
            Head[i] = id++;
        }

        printf("%d\n",SPFA(Left,Right));
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值