HDU 1491 Octorber 21st (日期计算)

Octorber 21st

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3993    Accepted Submission(s): 2449

Problem Description
HDU's 50th birthday, on Octorber 21st, is coming. What an exciting day!! As a student of HDU, I always want to know how many days are there between today and Octorber 21st.So, write a problem and tell me the answer.Of course, the date I give you is always in 2006.


 

Input
The input consists of T test cases. The number of T is given on the first line of the input file.Following T lines, which represent dates, one date per line. The format for a date is "month day" where month is a number between 1 (which indicates January) and 12 (which indicates December), day is a number between 1 and 31.All the date in the input are in 2006, you can assume that all the dates in the input are legal(合法).

Output
For each case, if the date is before Octorber 21st, you should print a number that between the date and Octorber 21st.If the day is beyond Octorber 21st, just print "What a pity, it has passed!".If the date is just Octorber 21st, print"It's today!!".

Sample Input
  
  
7 10 20 10 19 10 1 10 21 9 1 11 11 12 12

Sample Output
  
  
1 2 20 It's today!! 50 What a pity, it has passed! What a pity, it has passed!

Author
8600
 
AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[12]={31,28,31,30,31,30,31,31,30,31,30,31};
int i,j,k,l,m,n,x,y;
int main()
{
	scanf("%d",&k);
	while(k--)
	{
		scanf("%d%d",&x,&y);
		m=0;
		for(i=0;i<x-1;i++)
		m+=a[i];
		m+=y;
		if(m==294)
		printf("It's today!!\n");
		if(m>294)
		printf("What a pity, it has passed!\n");
		if(m<294)
		printf("%d\n",294-m);
	}
	return 0;
}

AC代码:
#include<stdio.h>
int a[11]={31,28,31,30,31,30,31,31,30};
int main()
{
    int i,t,m,d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&d);
        int s=0;
        if(m>10) printf("What a pity, it has passed!\n");
        else if(m==10 && d>21) printf("What a pity, it has passed!\n");
        else if(m==10 && d==21) printf("It's today!!\n");
        else
        {
            for(i=m-1;i<9;i++) s+=a[i];
            s+=21-d;
            printf("%d\n",s);
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值