PAT甲级1052. Linked List Sorting (25)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Key Next
where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.
Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.
Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

#include <cstdio>
using namespace std;
#include <algorithm>
#include <vector>

const int MAX=100001;

struct node{
    int address;
    int key;
    int next;
    int flag;
    node(){
        flag=0;
    }
}A[MAX];

bool compare(node x,node y){
    if(x.flag!=y.flag) return x.flag>y.flag;
    return x.key<y.key;
} 

int main(){
    int N,head;
    scanf("%d %d",&N,&head);

    for(int i=0;i<N;i++){
        node nd;
        scanf("%d %d %d",&nd.address,&nd.key,&nd.next);
        A[nd.address]=nd;
    }

    int cnt=0;
    for(int i=head;i!=-1;i=A[i].next){
        A[i].flag=1;
        cnt++;
    }

    if(cnt==0) printf("0 -1"); //易错点 
    else{
        sort(A,A+MAX,compare);

        for(int i=0;i<cnt;i++){
            A[i].next=A[i+1].address;
        }
        A[cnt-1].next=-1;

        printf("%d %05d\n",cnt,A[0].address);
        for(int i=0;i<cnt-1;i++){
            printf("%05d %d %05d\n",A[i].address,A[i].key,A[i].next);
        }
        printf("%05d %d -1\n",A[cnt-1].address,A[cnt-1].key);   }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值