POJ2828:Buy Tickets(线段树单点)

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The nextN lines contain the pairs of values Posi and Vali in the increasing order ofi (1 ≤ iN). For each i, the ranges and meanings ofPosi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind thePosi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the valueVali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

 
 
 
题意:有n个人,给出n个人要插入的位置与其价值,输出最后的价值
思路:由于整个队列是动态不断变化的,所以我们可以从最后一个插入的人开始逆推出所有人想要插入的队列并对线段树进行更新即可
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,ans[1000000];

struct node
{
    int n,val;
} a[1000000];

struct tree
{
    int l,r,n;
} b[1000000];

void init()
{
    int i,j,k;
    for(k = 1; k<n; k<<=1);
    for(i = k; i<2*k; i++)
    {
        b[i].l = b[i].r = i-k+1;
        b[i].n = 1;//每个叶子节点只能放入一人
    }
    for(i = k-1; i>0; i--)
    {
        b[i].l = b[2*i].l;
        b[i].r = b[2*i+1].r;
        b[i].n = b[2*i].n+b[2*i+1].n;//每个区间是其左右子树所能插入人数的总和
    }
}

void insert(int i,int x,int m)
{
    if(b[i].l == b[i].r)//找到叶子节点,这个节点存放该人,并且叶子节点能放的人数清0
    {
        ans[b[i].l] = m;
        b[i].n = 0;
        return;
    }
    if(x<=b[2*i].n)//其插入的位置若能放入左子树(还能放人),往左子树方向搜,否则走右子树
        insert(2*i,x,m);
    else
        insert(2*i+1,x-b[2*i].n,m);
    b[i].n--;//放完后,该节点的人数减一
}

int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        for(i = 1; i<=n; i++)
            scanf("%d%d",&a[i].n,&a[i].val);
        init();
        for(i = n; i>0; i--)//逆推
        {
            insert(1,a[i].n+1,a[i].val);
        }
        printf("%d",ans[1]);
        for(i = 2; i<=n; i++)
            printf(" %d",ans[i]);
        printf("\n");
    }

    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值