HDU4649:Professor Tian(概率)

Problem Description
Timer took the Probability and Mathematical Statistics course in the 2012, But his bad attendance angered Professor Tian who is in charge of the course. Therefore, Professor Tian decided to let Timer face a hard probability problem, and announced that if he fail to slove the problem there would be no way for Timer to pass the final exam. 
As a result , Timer passed. 
Now, you, the bad guy, also angered the Professor Tian when September Ends. You have to faced the problem too. The problem comes that there is an expression and you should calculate the excepted value of it. And the operators it may contains are '&' (and),'|'(or) and '^'(xor) which are all bit operators. For example: 7&3=3, 5&2=0, 2|5=7, 4|10=14, 6^5=3, 3^4=7.
Professor Tian declares that each operator O i with its coming number A i+1 may disappear, and the probability that it happens is P i (0<i<=n). 
 

Input
The input contains several test cases. For each test case, there is a integer n (0<n<=200) in the first line.In the second line, there are n+1 integers, stand for {A i}. The next line contains n operators ,stand for {O i}. The forth line contains {P i}. 
A i will be less than 2 20, 0<=P i<=1.
 

Output
For each text case, you should print the number of text case in the first line.Then output the excepted value of the expression, round to 6 decimal places.
 

Sample Input
  
  
2 1 2 3 ^ ^ 0.1 0.2 2 8 9 10 ^ ^ 0.5 0.78 1 1 2 & 0.5
 

Sample Output
  
  
Case 1: 0.720000 Case 2: 4.940000 Case 3: 0.500000
 

题意:
给你一个式子,第i位有pi说的概率消失掉,要计算最后值的期望

思路:
每个数二进制最多20位,我们对每一位为1的情况进行计算即可

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;

#define ls 2*i
#define rs 2*i+1
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 205
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define rank rank1
const int mod = 10007;

int n,a[N];
double dp[N],p[N],ans;
char op[N][5];

int main()
{
    int i,j,k,cas=1;
    while(~scanf("%d",&n))
    {
        for(i = 0; i<=n; i++)
            scanf("%d",&a[i]);
        for(i = 1; i<=n; i++)
            scanf("%s",op[i]);
        for(i = 1; i<=n; i++)
            scanf("%lf",&p[i]);
        ans = 0;
        for(i = 0; i<=20; i++)
        {
            double q;
            if(a[0]&(1<<i)) q = 1;
            else q = 0;
            for(j = 1; j<=n; j++)
            {
                if(a[j]&(1<<i))
                {
                    if(op[j][0]=='&')
                        continue;
                    else if(op[j][0]=='^')
                        q = q*p[j]+(1-q)*(1-p[j]);
                    else
                        q = q*p[j]+(1-p[j]);
                }
                else
                {
                    if(op[j][0]=='&')
                        q = q*p[j];
                    else
                        continue;
                }
            }
            ans += q*(1<<i);
        }
        printf("Case %d:\n%lf\n",cas++,ans);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值