POJ 3104 Drying(二分)

题目描述:
Drying
Time Limit: 2000MS Memory Limit: 65536K

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output
sample output #1
3
sample output #2
2

题目大意:
烘干衣服的最短时间,烘干机以k单位水/min的速度蒸发,自然的话是1单位水/min

题目分析:
求一个最短时间,其实的话二分最短时间就可以,主要就是二分函数咋写。首先要有一个时间记录,等轮到这个衣服的时候,先看靠自然烘干还剩下多少水,然后呢,剩下的水由由两部分蒸发掉,一个是自然烘干,另外一个是烘干机时间,设烘干时间为x,(传到二分函数的参数为t,就是烘干所有衣服的时间),那么自然时间为t-x,列出不等式
k*x+t-x>=water[i]-time,那么x=(water-time-t+k-2)/(k-1),所以注意k=1的时候单拿出来就好了

代码:

#include "cstdio"
#include "algorithm"
using namespace std;
int n,k,cloth[100005];

bool c(int t)
{
    int time=0;
    for (int i = 0; i < n; ++i)
    {
        int more=cloth[i]-t;
        if(more>0)
        {
            time+=(more+k-2)/(k-1);
            if(time>t){
                return false;
            }
        }
    }
    return true;
}

int main()
{
    int lb,ub;
    while(scanf("%d",&n)!=EOF)
    {
        for (int i = 0; i < n; ++i)
        {
            scanf("%d",&cloth[i]);
        }
        scanf("%d",&k);
        if(k==1)
        {
            printf("%d\n",*max_element(cloth,cloth+n));
        }
        else{
            lb=1,ub=*max_element(cloth,cloth+n);
            while(ub-lb>1)
            {
                int mid=(lb+ub)>>1;
                if(c(mid)) ub=mid;
                else lb=mid;
            }
            printf("%d\n",ub);
        }       
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值