关闭

mac系统xcode升级等软件更换appid账户

标签: Xcode更换appid无法更换appidimovie
9485人阅读 评论(0) 收藏 举报
分类:

       我们会遇到这样的问题,就是说当你的同事离职了,然后这个mac系统里的appid可能是他自的账户,然后苹果推出新的系统以及xcode等软件,这样我们升级xcode时,会提示我们输入密码,并且这个账户是不能修改的,难道要找以前的同事要密码,总不能一直用别人的账户吧,如果没有这个同事的联系方式,那不就头疼了,需要自己删除xcode,然后重新下载安装,重新下载很慢的,而且文件比较大。怎么办呢?

       两个解决办法:

       1.删除xcode,重新下载。

       2.更换appid账户(此账户必须以前下载安装过xcode,否则是没有用的,具体是否这样需要测试一下呗)。具体步骤如下:

        一:打开AppStore,注销以前的appid账户,登录自己需要的appid账户。

        二:打开Finder里的“应用程序”。

三:找到“Xcode”,然后右键“显示包内容”。

四:找到_MASReceipt文件夹,然后删除,最好重启一下AppStore,更新Xcode等软件即可。

这样两个方法就可以把以前的账户删除了,mac系统有些软件更code一样都是需要appid,更新时无法修改账户名,就可以通过前面两个方式解决问。


          

1
0
查看评论

Mac上的应用,例如Xcode需要输入原始下载账号才能更新问题

为了免下载安装Xcode,安装时使用了别人提供的Xcode.dmg安装,而非使用自己账号在AppStore下载的。      这样的安装模式会出现一个问题,更新Xcode时AppStroe会提示让你输入下载该Xcode的账号及密码,该账号不能直接修改。下面的方法可以...
  • lg767201403
  • lg767201403
  • 2016-03-18 16:06
  • 1369

iPhone开发--更改xcode中的Apple ID

现在的xcode的模拟器的最高版本貌似是5.1,我的xcode模拟器只有5.1。但是当我的程序运行在4.3的模拟器中时会偶尔出现不兼容的问题,所以我就想下载4.3的模拟器包,具体步骤如下: 1.打开xcode,并依次点击Xcode->Preferences 2.在新出现...
  • zcl369369
  • zcl369369
  • 2012-06-25 22:37
  • 21980

升级xcode时更换appid账户

为了免下载安装Xcode,安装时使用了别人提供的Xcode.dmg安装,而非使用自己账号在AppStore下载的。      这样的安装模式会出现一个问题,更新Xcode时AppStroe会提示让你输入下载该Xcode的账号及密码,该账号不能直接修改。下面的方法...
  • a416863220
  • a416863220
  • 2015-04-28 14:00
  • 787

升级xcode时更换appid账户

为了免下载安装Xcode,安装时使用了别人提供的Xcode.dmg安装,而非使用自己账号在AppStore下载的。      这样的安装模式会出现一个问题,更新Xcode时AppStroe会提示让你输入下载该Xcode的账号及密码,该账号不能直接修改。下面的方法...
  • zhuzhihai1988
  • zhuzhihai1988
  • 2014-10-05 16:09
  • 6089

升级mac自带的svn版本 升级xcode的svn版本

系统版本: MAC OS X 10.8.4 出现问题:Xcode以及Mac系统自带的SVN版本基本都是1.6,由于日常开发中使用的SVN版本都是1.7以上的,因此需要升级svn版本。【说明:使用1.6版本的SVN客户端checkout的代码,使用1.7版本的客户端的时候,可能会出一些版本不兼容...
  • zxc110110
  • zxc110110
  • 2015-06-24 11:37
  • 3672

更新Xcode是其他人的appleID怎么办?怎么使用新的appleID更新Xcode

为了免下载安装Xcode,安装时使用了别人提供的Xcode.dmg安装,而非使用自己账号在AppStore下载的。      这样的安装模式会出现一个问题,更新Xcode时AppStroe会提示让你输入下载该Xcode的账号及密码,该账号不能直接修改。下面的方法...
  • u014131398
  • u014131398
  • 2014-08-22 08:39
  • 1576

Mac-系统升级后无法安装其他来源的软件

问题描述当 Mac 系统升级后,只能安装 App Store 和 被认可的开发者来源的软件,如果安装其他来源的软件,就会直接失败,那么该怎么办?问题解决方法一:按住 Control 键点按 app 图标,然后选择“打开”- 用于免除身份不明的开发者的 Developer ID 签名保护。方法二:非常...
  • qq_32452623
  • qq_32452623
  • 2017-07-18 10:53
  • 1177

MacStore更新Xcode时提示帐户不对,更换帐户方法

为了免下载安装Xcode,安装时使用了别人提供的Xcode.dmg安装,而非使用自己账号在AppStore下载的。      这样的安装模式会出现一个问题,更新Xcode时AppStroe会提示让你输入下载该Xcode的账号及密码,该账号不能直接修改。下面的方法...
  • samuelltk
  • samuelltk
  • 2014-11-06 19:05
  • 4007

Qt-Xcode升级导致编译不过

mac下,不小心升级xcode,可能会到时Qt编译找不到相应的SDK版本,例如:升级前SDK是=11,升级XCODE后SDK=12,但Qt依然还是找到是SDK=11,从而导致编译不过,此时我们可以修改qt的安装目录下一个文件即可,我本机的qt目录是:/Users/mzw/Qt5.7.1/5.7/cl...
  • weinkym
  • weinkym
  • 2017-04-06 11:04
  • 474

macbook升级scipy和numpy

系统自带的scipy和numpy的版本比较低,编译scikit learn出现numpy.dtype
  • QIBAOYUAN
  • QIBAOYUAN
  • 2014-08-05 23:40
  • 4446
    个人资料
    • 访问:1318189次
    • 积分:11066
    • 等级:
    • 排名:第1929名
    • 原创:155篇
    • 转载:5篇
    • 译文:0篇
    • 评论:165条
    文章分类
    感谢打赏 支付宝二维码
    支付宝
    最新评论