poj 1742 Coins(多重背包)

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 31369 Accepted: 10679

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

LouTiancheng@POJ

背包问题,一定要多思考,,,参考大神代码

#include<stdio.h>
#include<set>
#include<algorithm>
#include<string.h>
using namespace std;
#define M 120
int val[M],cnt[M];
int dp[100020];// dp[i][j] := 用前i种硬币凑成j时第i种硬币最多能剩余多少个
//dp[j] := 在第i次循环时之前表示用前i-1种硬币凑成j时第i种硬币最多能剩余多少个
 //(-1表示配不出来),循环之后就表示第i次的状态
int n,m;
int main(){
	int i,j;
	while(scanf("%d%d",&n,&m),n+m){
		memset(dp,-1,sizeof(dp));
		for(i=0;i<n;i++)
			scanf("%d",&val[i]);
		for(i=0;i<n;i++)
			scanf("%d",&cnt[i]);
		dp[0]=0;
		for(i=0;i<n;i++)
			for(j=0;j<=m;j++){
				if(dp[j]>=0)
					dp[j]=cnt[i];
				else if(j<val[i] || dp[j-val[i]]<=0)
				 // 用一个就超出,不能用
				// 连凑比j小的数的时候都用完了,此时更加用完了
					dp[j]=-1;
				else
					dp[j]=dp[j-val[i]]-1;// 用上了一个第i个硬币
			}
		int ans=0;
		for(i=1;i<=m;i++)
			if(dp[i]>=0) ans++;
		printf("%d\n",ans);
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值