poj 1087 A Plug for UNIX(字符串编号建图)

A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14862 Accepted: 5026

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

Source

East Central North America 1999

题目大意:这题题目意思实在太难懂,不过题目意思搞清楚之后还是比较好做的
在这个题目里有两种物品,一个是插座,一个是电器插座只有一个插孔和一
个插头,电器只有一个插头首先有n种插座,n种插座用字符串表示,这n种插
座可以理解为是插在电源上的插座然后有m个电器,现在电器要充电,电器用
字符串表示,每个电器都有自己可以插的插座(这个插座可以不是那n个插在电
源上的插座,可以是其他的插座)现在有k个信息s1 s2代表s1插座可以插到s2
插座上去,这里类似于将插头转换了一下这些s1与s2也可以不是那n个插在电
源上的插座给出这些个信息问你还有多少个电器没有插座可以用
建图:
建一个源点,指向所有电器,容量为1
所有电器指向他们可以插的那个插头上,容量为1
如果一个插头可以插到另一个插头,那么将s1指向s2,容量为无限大
将所有插在电源上的插头指向汇点,容量为1


然后从源点到汇点求最大流即可
不过建图会比较复杂,因为涉及到字符串的处理,所以用map容器比较好做点

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue> 
#include<map> 
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define M 1000
struct node{
	int v,next,w;
}mp[M*M];
int head[M],dis[M],cnt,st,et;
void add(int u,int v,int w){
	mp[cnt].v=v;
	mp[cnt].w=w;
	mp[cnt].next=head[u];
	head[u]=cnt++;
	mp[cnt].v=u;
	mp[cnt].w=0;//有向图 
	mp[cnt].next=head[v];
	head[v]=cnt++;
}
int bfs(){
	memset(dis,-1,sizeof(dis));
	queue<int> q;
	while(!q.empty()) q.pop();
	dis[st]=0;
	q.push(st);
	while(!q.empty()){
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=mp[i].next){
			int v=mp[i].v;
			if(mp[i].w && dis[v]==-1){
				dis[v]=dis[u]+1;
				q.push(v);
				if(v==et)	return 1;
			}
		}
	}
	return 0;
}
int dinic(int u,int low){
	if(u==et || low==0) return low;
	int ans=low,i,a;
	for(i=head[u];i!=-1;i=mp[i].next){
		int v=mp[i].v;
		if(dis[v]==dis[u]+1 && mp[i].w && (a=dinic(v,min(ans,mp[i].w)))){
			mp[i].w-=a;
			mp[i^1].w+=a;//开始的时候写成mp[i].v,,找了半天错,擦擦擦擦擦 
			ans-=a;
			if(ans==0) return low;
		}
	}
	return low-ans;
}
int main(){
	int t,i,j,k,n,tot;
	char str[30],ch[30];
	scanf("%d",&n);
	map<string,int> m;
	cnt=0; tot=1;//给电器编号 
	memset(head,-1,sizeof(head));
	m.clear();
	st=0; et=M-1;//起点,终点 
	for(i=0;i<n;i++){
		scanf("%s",str);
		m[str]=tot++;
		add(m[str],et,1);
	}
	
	scanf("%d",&t);
	for(i=0;i<t;i++){
		scanf("%s %s",str,ch);
		m[str]=tot++;
		if(!m[ch])  m[ch]=tot++;
		add(st,m[str],1);
		add(m[str],m[ch],1);	
	}
	scanf("%d",&k);
	for(i=0;i<k;i++){
		scanf("%s %s",str,ch);
		if(!m[str]) m[str]=tot++;
		if(!m[ch]) m[ch]=tot++;
		add(m[str],m[ch],inf);
 	}
	int ans=0;
	while(bfs()){
		ans+=dinic(st,inf);
	}
	printf("%d\n",t-ans);
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值