HDU1727数字转换成英文

128 篇文章 4 订阅
95 篇文章 4 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1727

Hastiness

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1297    Accepted Submission(s): 495

Problem Description
How many problems did you AC?
When you read this problem, don’t hasty and careless, this is also simple, haha, I didn’t cheat you.
The game over soon, WisKey starts using English begin countdown. He not only have no gene in math, but also bad in English. Fortunately, He met you who have gift in programming. So please help him to translate. 

 
Input
Give you an integer T, output T in English, and note that all of words are lower case. (0<=T<=9999)
 
Output
One answer One line.
Details see sample.

 
Sample Input
  
  
2034 1234 123 24 0
 
Sample Output
  
  
two thousand and thirty-four one thousand and two hundred and thirty-four one hundred and twenty-three twenty-four zero
 
题目:题目意思就是将一个数字按照英文习惯输出,比较麻烦,关键是细心。
#include <stdio.h>

char tab[][20] = {
    "zero", "one", "two", "three", "four", "five",
    "six", "seven", "eight", "nine", "ten", "eleven",
    "twelve", "thirteen", "fourteen", "fifteen",
    "sixteen", "seventeen", "eighteen", "nineteen", "twenty"};

char dec[][20] = {
    "zero", "ten", "twenty", "thirty", "forty", "fifty", "sixty", "seventy", 
    "eighty", "ninety", "hundred"};

int main ()
{
    int n;
    while (scanf ("%d", &n)!=EOF)
    {
        if (n == 0)
        {
            puts ("zero") ;
            continue ;
        }
        
        if (n >= 1000)
		{
            printf ("%s thousand", tab[n/1000]);
			//n -= n/1000*1000 ;
			n = n % 1000;
            if (n != 0) printf (" and ") ;
        }
        if (n >= 100)
		{
            printf ("%s hundred", tab[n/100]);
			//n -= n/100*100 ;
			n = n % 100;
            if (n != 0) printf (" and ") ;
        }
        if (n != 0)
        {
            if (n <= 20) printf ("%s", tab[n]) ;
            else
            {
                printf ("%s", dec[n/10]) ;
                if (n%10!=0) 
					printf ("-%s", tab[n%10]) ;
            }
        }
        printf ("\n") ;
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Raise

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值