poj2063 & hdu1963 Investment 又是DP啦,,经典完全背包问题

154 篇文章 1 订阅
26 篇文章 0 订阅
Investment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8879 Accepted: 3047

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
ValueAnnual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050
 
简单背包,,但是数据的范围非常大,,所以做点处理,题目说债券的价格和初始的资金都是一千的倍数,所以就除以1000喽,,注意千万别使用double类型的数据,我就被坑了两次!详情请看代码:
 
#include <stdio.h>
#include <string.h>
#define MAX 1000000

struct Bond{
	int kind,inte;
}bond[50];

int dp[MAX] ;


int max(int a , int b)
{
	return a>b?a:b ;
}

int main()
{
	int n ;
	scanf("%d",&n) ;
	while(n--)
	{
		int start , year;
		scanf("%d%d",&start,&year) ;
		int d;
		scanf("%d",&d) ;
		for(int i = 0 ; i < d ; ++i)
		{
			scanf("%d%d",&bond[i].kind,&bond[i].inte) ;
			bond[i].kind/=1000 ;
		}
		int sum = start/1000 ,ans = start ;
		while(year--)
		{
			memset(dp,0,sizeof(int)*(sum+10)) ;
			for(int i = 0 ; i < d ; ++i)
			{
				for(int j = bond[i].kind ; j <= sum ; ++j)
				{
					dp[j] = max(dp[j],dp[j-bond[i].kind]+bond[i].inte) ;
				}
			}
			ans += dp[sum];
			sum = ans/1000;
		}
		printf("%d\n",ans) ;
	}
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值