hdu 1115 Lifting the Stone 计算几何

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5818    Accepted Submission(s): 2438


Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.
 

Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.
 

Sample Input
  
  
2 4 5 0 0 5 -5 0 0 -5 4 1 1 11 1 11 11 1 11
 

Sample Output
  
  
0.00 0.00 6.00 6.00
 
老规矩,上博客:
http://www.cnblogs.com/jbelial/archive/2011/08/08/2131165.html
http://blog.csdn.net/cs_zlg/article/details/7870799

代码:
#include <stdio.h>
#define MAX 1000010

struct Point{
	double x, y ;
}p[3];

int main()
{
	int t ;
	scanf("%d",&t) ;
	while(t--)
	{
		double sumArea = 0.0 , sumX = 0.0 , sumY = 0.0 ;
		int n  ;
		scanf("%d",&n);
		scanf("%lf%lf%lf%lf",&p[0].x,&p[0].y,&p[1].x,&p[1].y) ;
		for(int i = 0 ; i < n-2 ; ++i)
		{
			scanf("%lf%lf",&p[2].x,&p[2].y) ;
			double s = ((p[1].x-p[0].x)*(p[2].y-p[0].y)-(p[2].x-p[0].x)*(p[1].y-p[0].y))/2 ;
			sumX += (p[0].x+p[1].x+p[2].x)*s ;
			sumY += (p[0].y+p[1].y+p[2].y)*s ;
			sumArea += s ;
			p[1] = p[2] ; 
		}
		printf("%.2lf %.2lf\n",sumX/3/sumArea,sumY/3/sumArea) ;
	}
	return 0 ;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值