杭电OJ——1051 Wooden Sticks

31 篇文章 1 订阅
3 篇文章 0 订阅

Wooden Sticks




Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 
 这算是我第一次比较系统的接触贪心算法!感觉比较差!题目做不出!但是我听说过一句很经典的话,拿出来和大大家共勉一下吧!“失败并不是什么丢人的事情,从失败中全无收获才是!”,对,题目做不出没有什么丢人,从题目中毫无收获才是!

我参考了别人的代码,结合自己的理解,总结一下知识点以及注意点吧!

这道题目是先要排序的,按照长度或者重量排都可以,当长度(重量)相同时就按照重量(长度)排,从大到小或从小到大都可以!这里我懂的,没有问题!
排序之后,问题就可以简化,(假设按照长度不等时长度排,长度等是按照重量排, 我假设按照从大到小来排! )即求排序后的所有的重量值 最少能表示成几个集合。长度就不用再管了,从数组第一个数开始遍历,只要重量值满足条件,那么这两个木棍就满足条件!

刚开始我不懂,为什么用贪心可以找出最优解!也在这个问题上纠结了很久,感觉比较痛苦!后来通过自己苦想,还是想了出来!
注意:在这里通过贪心或者动归算出来的结果没有不同,即用贪心也可以解出,并且效率比动归高!
这是由这道题的数据的特殊性决定的!

有一些规则需要注意:
用一幅图来描述吧!


参考代码如下:
//几天不敲代码,感觉退化了!又粗心死了!

#include<iostream>
#include<algorithm>
using namespace std;

struct SIZE
{
	int l;
	int w;
}sticks[5005];
int flag[5005];

bool cmp(const SIZE &a,const SIZE &b)//这里是排序!
{//写排序函数的时候要特别的小心!
	//if(a.w!=b.w)//这里写错了,这里表示如果重量不等,按照长度排,如果重量相等,则按照重量排!(没意义!)
	if(a.l!=b.l)
		return a.l>b.l;//长度不等时按照长度排,从大到小排
	else
		return a.w>b.w;//长度相等时,再按照重量从大到小排列
}

int main()
{
	int n,min,cases;
	int i,j,s;
	

	cin>>cases; 
	for(j=0;j<cases;j++)
	{
		cin>>n;
		for(i=0;i<n;i++)
		{
			cin>>sticks[i].l>>sticks[i].w;
			flag[i]=0;
		}
		sort(sticks,sticks+n,cmp);

		s=0;
		for(i=0;i<n;i++)
		{
			if(flag[i]) continue;
			min=sticks[i].w;

			for(int j=i+1;j<n;j++)
			{
				if(min>=sticks[j].w && !flag[j])
				{
					min=sticks[j].w;
					flag[j]=1;
				}
			}
			s++;
		}
		cout<<s<<endl;
	}
	//system("pause");
	return 0;
}


  • 11
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值