Avoid The Lakes

Avoid The Lakes

1000ms
1000ms
65536KB
64-bit integer IO format: %lld      Java class name: Main
Font Size:

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4
这道搜索题,搜了我好久就没出正确结果。看着别人的AC代码,也没找出错误。找了好久才发现自己的数组下标从零开始出问题了。哎!以后还是少从零开始吧。
#include<iostream>
#include<algorithm>
#include<functional>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<stack>
#define MAX(x,y) x>y?x:y;
#define MIN(x,y) x<y?x:y;
using namespace std;
int map[110][110];
int mark[110][110];
int n,m,k,key;
int dfs(int x,int y)
{
    int i;
    const int dir[4][2]={-1,0,1,0,0,1,0,-1};
    for(i=0;i<4;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx>=1&&yy>=1&&xx<=n&&yy<=m&&map[xx][yy]==1&&!mark[xx][yy])
        {
            mark[xx][yy]=1;
            key++;
            dfs(xx,yy);
        }
    }
    return key;
}
int main()
{
    int i,j,x,y,ans;
    while(cin>>n>>m>>k)
    {
        ans=0;
        memset(map,0,sizeof(map));
        memset(mark,0,sizeof(mark));
        for(i=0;i<k;i++)
        {
            cin>>x>>y;
            map[x][y]=1;
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                if(map[i][j]==1&&!mark[i][j])
                {
                    key=1;
                    mark[i][j]=1;
                    ans=MAX(ans,dfs(i,j));
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值