使用gem安装Jekyll时遇到Gem::RemoteFetcher::FetchError错误

原创 2015年11月20日 17:38:41

首先安装ruby环境(注:此处的环境都是windows环境),我安装的版本是2.2.3的,ruby的环境配置好以后,打开命令终端,输入: gem install jekyll出现如下错误:


经过谷歌查询以后发现是镜像的问题,详情可以到如下网站了解:

https://ruby.taobao.org/ 点击打开链接


然后输入如下命令:

gem sources --add https://ruby.taobao.org/ --remove https://rubygems.org/


结果:



这个就可以了,然后就可以安装其他的模块了。


gem install显示错误(Gem::RemoteFetcher::FetchError)

今天想试下http://fir.im的官方工具 fir-cli ,于是执行命令sudo gem install fir-cli --no-ri --no-rdoc不料,竟然返回错误信息ERROR: ...

jekyll gem

  • 2014年11月26日 23:46
  • 13.8MB
  • 下载

安装nokogiri 以及gem 的时候错误总结

1、第一个错误信息 ============================================================================== ERROR:  E...
  • ls1160
  • ls1160
  • 2014年07月27日 13:07
  • 1743

在ubuntu 14.04 64bit上安装rails遇到的一些gem问题

上次心血来潮买了部云服务器,准备在上面部署rails项目,通过命令apt-get install ruby-full(前提这个得连上网)安装完ruby后,安装rails的时候出现了几个令人头疼的gem...

cocoapods 的安装使用及gem的常用命令

概念:cocoapods是开发OS X 和iOS 应用程序的一个第三方库的依赖管理工具 安装: # 添加源 $ sudo gem sources -a http://ruby....
  • sajiner
  • sajiner
  • 2015年05月05日 09:33
  • 333

使用gem安装rails,付解决It seems your ruby installation is missing psych (for YAML output).

http://blog.csdn.net/abbuggy/article/details/8181064 在前面,我们学会了使用RVM的作用和利用RVM安装ruby并管理其版本的方法。 下一步...
  • ABBuggy
  • ABBuggy
  • 2012年11月15日 00:03
  • 8784

常用gem的安装使用

常用gem的安装及使用步骤

安装gem5遇到的问题及解决方案

gem5仿真软件的安装

亚马逊服务器gem安装插件遇到没有权限的问题

亚马逊服务器gem安装插件的权限问题

windows 下安装部分gem时出现 Could not create Makefile due to some reason 的解决办法

现象描述: 如果你安装某个需要本地编译代码的gem 时出现了类似如下的错误,则符合本文章所谈论的情况: C:/Develop/Ruby193/bin/ruby.exe extconf.rb ch...
  • woncomp
  • woncomp
  • 2013年04月11日 09:21
  • 1730
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:使用gem安装Jekyll时遇到Gem::RemoteFetcher::FetchError错误
举报原因:
原因补充:

(最多只允许输入30个字)