《字符串》— HDU 2594 Simpsons’ Hidden Talents(KMP+A串的前n个字符与B串的后n个字符相同,使n尽可能大)

Simpsons’ Hidden Talents

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8831    Accepted Submission(s): 3079

 

 

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

 

 

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

 

 

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

 

 

Sample Input

 

clinton homer riemann marjorie

 

 

Sample Output

 

0 rie 3

 

 

Source

HDU 2010-05 Programming Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1686 2595 2596 2597 2598 

 

#include <iostream>  
#include <stdio.h>  
#include <string.h>  
#include <stdlib.h>  
#include <algorithm>  
using namespace std;  
typedef long long ll;  
const int inf=0x3f3f3f3f;  
const int maxn=100010;  
const int mod=10007;  
char str1[maxn],str2[maxn];  
int Next[maxn];  
void makenext(int m){  
    int i=0,j=-1;  
    Next[i]=-1;  
    while(i<m){  
        if(j==-1||str1[i]==str1[j])  
            Next[++i]=++j;  
        else j=Next[j];  
    }  
}  
//int KMP(int n,int m){  
//    int i=0,j=0,ans=0;  
//    while(i<n){  
//        if(j==-1||str2[i]==str1[j]) i++,j++;  
//        else j=Next[j];  
//        if(j==m){  
//            ans++;j=Next[j-1];i--;  
//        }  
//    }  
//    return ans;  
//}  
int main(){  
    while(scanf("%s%s",str1,str2)!=-1){  
        int len1=strlen(str1);  
        int len2=strlen(str2);  
        strcat(str1,str2);  
        int len=strlen(str1);  
        makenext(len);  
        int ans=Next[len];  
        if(ans==0) printf("0\n");  
        else if(ans>=len1||ans>=len2){  
            if(len1<len2){  
                for(int i=0;i<len1;i++) printf("%c",str1[i]);  
                printf(" %d\n",len1);  
            }else{  
                printf("%s %d\n",str2,len2);  
            }  
        }else{  
            for(int i=0;i<ans;i++) printf("%c",str1[i]);  
            printf(" %d\n",ans);  
        }  
    }  
    return 0;  
}  

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值