1751 Highways【最小生成树】

Highways
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11033 Accepted: 3127 Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意:

给出n个点的坐标,给出他们之间已经连通的编号,输出还需要哪几个点相连可以达到所有的点直接或间接相连,而且总路径最短。


题解:

最小生成树的题目,刚开始想得比较复杂,后来仔细一分析,发现,只要在加边的时候,成功加入就输出对应的编号就可以了,不过因为oj的问题,需要用g++提交才能ac,很多次这样的现象了,也是醉了..具体看代码注释


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int a[800],b[800],per[800],n,cnt,kase;
struct lu
{
	int a,b;
	double len;
}x[600005];
double dis(int i,int j)
{
	return sqrt((a[i]-a[j])*(a[i]-a[j])*1.0+(b[i]-b[j])*(b[i]-b[j]));//其实完全不必求出距离,只要有个大小顺序就行
}
void init()
{
	for(int i=1;i<=n;++i)
	{
		per[i]=i;
	}
}
bool cmp(lu a,lu b)
{
	return a.len<b.len;
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	int i=x,j;
	while(i!=r)
	{
		j=per[i];per[i]=r;i=j;
	}
	return r;
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		per[fy]=fx;
		++cnt;kase=1;
	}
}
void kruskal(int c)
{
	double sum=0;
	for(int i=0;i<c&&cnt<n-1;++i)
	{
		kase=0;
		join(x[i].a,x[i].b);
		if(kase)
		{
			printf("%d %d\n",x[i].a,x[i].b);//输出新加的顶点
		}
	}
}
int main()
{
	int i,j,u,v;
	scanf("%d",&n);
	for(i=0;i<n;++i)
	{
		scanf("%d%d",a+i,b+i);
	}
	init();
	int c=cnt=0,m;
	scanf("%d",&m);
	for(i=0;i<m;++i)
	{
		scanf("%d%d",&u,&v);
		join(u,v);
	}
	for(i=0;i<n-1;++i)
	{
		for(j=i+1;j<n;++j)
		{
			x[c].a=i+1;x[c].b=j+1;
			x[c].len=dis(i,j);
			++c;
		}
	}
	sort(x,x+c,cmp);
	kruskal(c);//调用函数
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值