Hdu 1432 Lining Up【简单几何】

Lining Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1343 Accepted Submission(s): 385


Problem Description
``How am I ever going to solve this problem?" said the pilot.


Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input
The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. No pair will occur twice in one test case.


Output
For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.

Sample Input
  
  
5 1 1 2 2 3 3 9 10 10 11

Sample Output
  
  
3


题意:

给出一些点的坐标,问最多有多少点在同一条直线上......


题解:

每次固定一个点,枚举其他各个点和这个点连成的直线,直线斜率相等的肯定在同一条直线上

比赛做的时候,考虑的有点多,把整个直线的方程都求出来了,后来想想,只需要求斜率就好了.....


/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=705;
struct point 
{
	int y,x;
}x[maxn];
struct line
{
	int kase;//标记是否有斜率 
	double k;
}y[maxn*maxn];

int cmp(line a,line b)
{
	if(a.kase==b.kase)
	{
		return a.k<b.k;
	}
	return a.kase<b.kase;
}
line cal(point a,point b)
{
	line tp={0,0};
	int ty=a.y-b.y,tx=a.x-b.x;
	if(tx==0)//斜率不存在 
	{
		tp.kase=0;
	}
	else//斜率存在,求直线 
	{
		tp.kase=1;
		tp.k=ty*1.0/tx;
	}
	return tp;
}
bool ok(line a,line b)
{
	return a.kase==b.kase&&a.k==b.k;
}
int slove(int n)
{
	int ans=0;
	for(int i=0;i<n;++i)
	{
		int cnt=0;
		for(int j=0;j<n;++j)
		{
			if(i==j)
			{
				continue;
			}
			y[cnt]=cal(x[i],x[j]);
			++cnt;
		}
		sort(y,y+cnt,cmp);
		int tp=1;
		for(int j=1;j<cnt;++j)
		{
			if(ok(y[j],y[j-1]))
			{
				++tp;
			}
			else
			{
				tp=1;
			}
			ans=max(ans,tp);
		}
	}
	return ans+1;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d%d",&x[i].y,&x[i].x);
		}
		printf("%d\n",slove(n));
	}
	return  0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值