Hdu 1501 Zipper【dfs】

36 篇文章 0 订阅

Zipper

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9212 Accepted Submission(s): 3263


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.


Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no

Source


非常简单的dfs ,结果各种错误都犯了.......


#include<cstdio>
#include<cstring>
const int maxn=1005;
char a[maxn],b[maxn],c[2*maxn];
bool vis[maxn][maxn],kase;
void dfs(int la,int lena,int lb,int lenb)
{
	if(la>lena||lb>lenb||vis[la][lb])
	{
		return;
	}
	if(la==lena&&lb==lenb)
	{
		kase=1;
		return;
	}
	vis[la][lb]=1;
	if(!kase&&a[la]==c[la+lb])
	{
		dfs(la+1,lena,lb,lenb);
	}
	if(!kase&&b[lb]==c[la+lb])
	{
		dfs(la,lena,lb+1,lenb);
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		kase=0;
		memset(vis,0,sizeof(vis));
		scanf("%s%s%s",a,b,c);
		printf("Data set %d: ",i);
		dfs(0,strlen(a),0,strlen(b));
		printf("%s\n",kase?"yes":"no");
	}
	return 0;
}


#include<stdio.h>
#include<string.h>
const int maxn=205;
char a[maxn],b[maxn],c[maxn*2];
bool vis[maxn][maxn];
bool ok(int la,int lena,int lb,int lenb)
{
	if(la==lena&&lb==lenb)
	{
		return 1;
	}
	int kase=0;
    if((la<lena||lb<lenb)&&!vis[la][lb])
    {
    	vis[la][lb]=1;
        if(a[la]==c[la+lb])
        {
            kase=ok(la+1,lena,lb,lenb);
        }
        if(b[lb]==c[la+lb])
        {
            kase=kase||ok(la,lena,lb+1,lenb);
        }
    }
    return kase;
}
int main()
{
    int t,i,j,k,l;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
    	memset(vis,0,sizeof(vis));
        scanf("%s%s%s",a,b,c);
        printf("Data set %d: ",i);
        printf("%s\n",ok(0,strlen(a),0,strlen(b))?"yes":"no");
    }
    return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值