Error Curves

Error Curves

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 28   Accepted Submission(s) : 21
Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm's efficiency, she collects many datasets. What's more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0. [center][img]../../data/images/3714-1.jpg[/img][/center] It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
 

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input
  
  
2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output
  
  
0.0000 0.5000
 
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
    double a, b, c;
}str[10010];
int n;
double f(double x)
{    
    double max , y;
    max = str[0].a*x*x + str[0].b*x + str[0].c;
    for (int i = 1; i<n; i++)
    {
        y = str[i].a*x*x + str[i].b*x + str[i].c;
        if (y>max) max = y;
    }
    return max;
}
double sernary_search(double L, double R)
{
    double mid1, mid2;
    if (L > R) swap(L, R);
    while (R - L > 1e-10)
    {
        mid1 = L + (R - L) / 3.0;  //  mid1=(L+R)/2;
        mid2 = R - (R - L) / 3.0;  //  mid2=(mid1+R)/2;
        if (f(mid1) >= f(mid2)) L = mid1;
        else R = mid2;
    }
    return L;
}
int main()
{    
    int t;
    scanf("%d", &t);
    while (t--)
    {    
        double ans, ans1;
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
        scanf("%lf%lf%lf", &str[i].a, &str[i].b, &str[i].c);
        ans1 = sernary_search(0.0, 1000.0);
        ans = f(ans1);
        printf("%0.4lf\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值