问题一百二十七:Keep on Truckin

Description

Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

Input

Input to this problem will consist of multiple data sets. Each data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

The data sets end with a negetive integer.

Output

There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the smallest underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).
The height of the 18-wheeler is 168 inches.

Sample Input

180 160 170
-1

Sample Output

CRASH 160
  
#include <stdio.h>

int main()
{
    int i;
	int j;
	int t;
	int flag;
	int num[3];

	while(scanf("%d", &num[0])!=EOF && num[0]>=0)
	{
	      scanf("%d %d", &num[1], &num[2]);
          
		  flag=0;

		  for(i=0; i<2; i++)
		  {
		     for(j=i+1; j<3; j++) 
			 {
			     if(num[i]>num[j])
				 {
				    t= num[i];
					num[i]= num[j];
					num[j]= t;
				 }
			 }
		  }

		  for(i=0; i<3; i++)
		  {
		      if(num[i]<=168)
			  {
			      flag=1;
				  break;
			  }
		  }

		  if(flag)
		  {
		     printf("CRASH %d\n", num[i]);
		  }
		  else
		  {
		      printf("NO CRASH\n");
		  }
	}
    
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值