poj1247(Magnificent Meatballs)

这个题很简单也没有什么值得注意的trick,所以直接发代码

Magnificent Meatballs
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5027 Accepted: 3383

Description

Sam and Ella run a catering service. They like to put on a show when serving meatballs to guests seated at round tables. They march out of the kitchen with pots of meatballs and start serving adjacent guests. Ella goes counterclockwise and Sam goes clockwise, until they both plop down their last meatball, at the same time, again at adjacent guests. This impressive routine can only be accomplished if they can divide the table into two sections, each having the same number of meatballs. You are to write a program to assist them.

At these catering events, each table seats 2 <= N <= 30 guests. Each guest orders at least one and at most nine meatballs. Each place at the table is numbered from 1 to N, with the host at position 1 and the host's spouse at position N. Sam always serves the host first then proceeds to serve guests in increasing order. Ella serves the spouse first, then serves guests in decreasing order. The figures illustrate the first two example input cases.

Input

Input consists of one or more test cases. Each test case contains the number of guests N followed by meatballs ordered by each guest, from guest 1 to guest N. The end of the input is a line with a single zero.

Output

For each table, output a single line with the ending positions for Sam and Ella, or the sentence indicating an equal partitioning isn't possible. Use the exact formatting shown below.

Sample Input

5 9 4 2 8 3
5 3 9 4 2 8
6 1 2 1 2 1 2
6 1 2 1 2 1 1
0

Sample Output

Sam stops at position 2 and Ella stops at position 3.
No equal partitioning.
No equal partitioning.
Sam stops at position 3 and Ella stops at position 4.

Source

#include<cstdio>
#include<iostream>

#define MAXN 35

using namespace std;

int seat[MAXN];
int n;
int main(){
    while(scanf("%d", &n) && n != 0){
        int sum = 0;
        for(int i = 1; i <= n; i++){
            scanf("%d",&seat[i]);
            sum+=seat[i];
        }
        if(sum%2!=0){
            printf("No equal partitioning.\n");
        }
        else{
            int i = 1,sumi = 0;
            int j = n,sumj = 0;
            while(sumi< sum/2){
                sumi+=seat[i];
                i++;
            }
            while(sumj<sum/2){
                sumj+=seat[j];
                j--;
            }
            if(sumi == sumj && j - i +2== 1){//由于上面的while循环完成后,i多加了1,j多减了1;
                printf("Sam stops at position %d and Ella stops at position %d.\n", i-1, j+1);
            }
            else{
                printf("No equal partitioning.\n");
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值