poj 1979 Red and Black(BFS)

27 篇文章 0 订阅
5 篇文章 0 订阅

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31221 Accepted: 17047

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

分析:简单的BFS,模板

代码如下:

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
char map[25][25];
int dir[4][2]={-1,0,0,-1,1,0,0,1};
struct node{
	int x,y;
}point;
queue <node> q;
int main()
{
	int n,m,i,j;
	while(scanf("%d %d",&n,&m),n||m)
	{
		memset(map,0,sizeof(map));
		int sx=0,sy=0;
		for(i=1;i<=m;i++)
		{
			getchar();
			for(j=1;j<=n;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					point.x=i;point.y=j;
				}
			}
				
		}
		q.push(point);
		map[point.x][point.y]='#';
		int num=0;
		while(!q.empty())
		{
			point=q.front();
			q.pop();
			num++;
			for(i=0;i<4;i++)
			{
				node temp;
				temp.x=point.x+dir[i][0];
				temp.y=point.y+dir[i][1];
				if(map[temp.x][temp.y]!='#' && temp.x>=1 && temp.x<=m && temp.y>=1 && temp.y<=n)
				{
					map[temp.x][temp.y]='#';	
					q.push(temp);
				}
			}
		}
		printf("%d\n",num);
	}
	
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值