HDU 1087 Super Jumping! Jumping! Jumping!(DP)

77 篇文章 0 订阅
17 篇文章 0 订阅

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36136    Accepted Submission(s): 16478


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
  
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
  
  
4 10 3
 

Author
lcy

题意:一些棋子,只能从小的跳到大的,可以隔着跳,最后问,跳的棋子值的和最大为多少。
分析:这个题是一个求最大递增子序列和的问题。一开始把问题想简单了,弄成贪心求解,只判断了当前这个棋子加上值大还是不加值大,示例坑过了,进了个大坑。这个题目是一道动态规划题目,和最长递增序列类似。只需要求,把当前第i个棋子加上的最大价值,即:

dp[ i ] = max{a[ i ] , dp[ j ] + a[ i ]}

其中要保证,a[ j ] < a[ i ]。递推方程写出来出了,代码就容易了。

代码如下:

#include <stdio.h>
#include <string.h>
int a[1005];
long long dp[1005];
int main()
{
	int n;
	int i,j;
	while(scanf("%d",&n),n)
	{		
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
			scanf("%d",a+i);
		long long ans=-1;
		for(i=0;i<n;i++)
		{
			dp[i]=a[i];
			for(int j=0;j<i;j++)
			{
				if(a[i]>a[j] && dp[j]+a[i]>dp[i])
					dp[i]=dp[j]+a[i];
			}
			if(dp[i]>ans)
				ans=dp[i];
		}
		printf("%I64d\n",ans);	
	}
		
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值