uva 11044 Searching for Nessy

            uva 11044 Searching for Nessy 


Description

Download as PDF


  Searching for Nessy 

The Loch Ness Monsteris a mysterious and unidentified animal said to inhabit Loch Ness, 
a large deep freshwater loch near the city of Inverness in northern Scotland. Nessie is usually categorized as a type of lake monster.

http://en.wikipedia.org/wiki/Loch_Ness_Monster


In July 2003, the BBC reported an extensive investigation of Loch Ness by a BBC team, using 600 separate sonar beams, found no trace of any ¨sea monster¨ (i.e., any large animal, known or unknown) in the loch. The BBC team concluded that Nessie does not exist. Now we want to repeat the experiment.


Given a grid of n rows and m columns representing the loch, 6$ \le$n, m$ \le$10000, find the minimum number s of sonar beams you must put in the square such that we can control every position in the grid, with the following conditions:

  • one sonar occupies one position in the grid; the sonar beam controls its own cell and the contiguous cells;
  • the border cells do not need to be controlled, because Nessy cannot hide there (she is too big).

For example,


$\textstyle \parbox{.5\textwidth}{\begin{center}\mbox{}\epsfbox{p11044.eps}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\mbox{}\epsfbox{p11044a.eps}\end{center}}$

\epsfbox{p11044b.eps}

where X represents a sonar, and the shaded cells are controlled by their sonar beams; the last figure gives us a solution.

Input 

The first line of the input contains an integer, t, indicating the number of test cases. For each test case, there is a line with two numbers separated by blanks, 6$ \le$n, m$ \le$10000, that is, the size of the grid (n rows and m columns).

Output 

For each test case, the output should consist of one line showing the minimum number of sonars that verifies the conditions above.

Sample Input 

 
3
6 6
7 7
9 13

Sample Output 

 
4
4
12

题目大意:求m*n的网格中能放最多几个3*3的正方形。

解题思路:(m/3)*(n/3)



  <span style="font-family:SimSun;font-size:14px;">#include<stdio.h>  
    int main(){  
		int m, n, cnt;
		scanf("%d", &cnt);  
		while(cnt--){  
			scanf("%d%d", &m, &n);  
			printf("%d\n", (m / 3) * (n / 3));  
		}  
		return 0;
	</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值