uva 140 Bandwidth (全排列+暴力枚举)

                                uva 140 Bandwidth


Given a graph (V,E) where V is a set of nodes and E is a set of arcs in VxV, and an ordering on the elements in V, then the bandwidth of a node v is defined as the maximum distance in the ordering between v and any node to which it is connected in the graph. The bandwidth of the ordering is then defined as the maximum of the individual bandwidths. For example, consider the following graph:

picture25

This can be ordered in many ways, two of which are illustrated below:

picture47

For these orderings, the bandwidths of the nodes (in order) are 6, 6, 1, 4, 1, 1, 6, 6 giving an ordering bandwidth of 6, and 5, 3, 1, 4, 3, 5, 1, 4 giving an ordering bandwidth of 5.

Write a program that will find the ordering of a graph that minimises the bandwidth.

Input

Input will consist of a series of graphs. Each graph will appear on a line by itself. The entire file will be terminated by a line consisting of a single #. For each graph, the input will consist of a series of records separated by `;'. Each record will consist of a node name (a single upper case character in the the range `A' to `Z'), followed by a `:' and at least one of its neighbours. The graph will contain no more than 8 nodes.

Output

Output will consist of one line for each graph, listing the ordering of the nodes followed by an arrow (->) and the bandwidth for that ordering. All items must be separated from their neighbours by exactly one space. If more than one ordering produces the same bandwidth, then choose the smallest in lexicographic ordering, that is the one that would appear first in an alphabetic listing.

Sample input

A:FB;B:GC;D:GC;F:AGH;E:HD
#

Sample output

A B C F G D H E -> 3


题目大意:给出一些点,以及所有必须相连的两点,然后每个排序中,找出必须连接的距离最大值,然后在所有序列中找出连接所需最短的。

解题思路:先将节点关系构成一张表,然后根据表进行全排列进行枚举(利用next_permutation函数),找出最小带宽。


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
char ch[10], ch2[10];
int A[30][30], Max, Min, a[26];
int find(char a) {
	for (int i = 0; i < 10; i++) {
		if (ch[i] == a) return i;
	}
}
void getMin() { //找出给排列情况的带宽
	int temp1, temp2, num;
	for (int i = 0; i < 26; i++) {
		for (int j = 0; j < 26; j++) {
			if (A[i][j]) {
				temp1 = find(i + 'A');	
				temp2 = find(j + 'A');
				num = abs(temp1 - temp2);
				if (Max < num) {
					Max = num;
				}
			}
		}
	}
}
int main() {
	char str[100];
	while (scanf("%s", str) == 1 && strcmp(str, "#") != 0) {
		memset(A, 0, sizeof(A));
		memset(a, 0, sizeof(a));
		int len = strlen(str);
		int cnt1, cnt2 = 0, flag = 1;
		for (int i = 0; i < len; i++) { //构成一张关系表
			if (str[i] >= 'A' && str[i] <= 'Z') {
				a[str[i] - 'A']++;
				if (flag) {
					cnt1 = str[i] - 'A';
				}
				else {
					A[cnt1][str[i] - 'A'] = 1;
				}
			}
			else if (str[i] == ':') flag = 0;
			else if (str[i] == ';') flag = 1;
		}
		memset(ch, 0, sizeof(ch));
		memset(ch2, 0, sizeof(ch2));
		for (int i = 0; i < 26; i++) {//找出出现过的节点字母编号
			if (a[i] != 0) ch[cnt2++] = i + 'A';
		}
		Min = 10;
		sort(ch, ch + strlen(ch));//排序,为全排列做准备
		do{                         //全排列找出最小带宽
			Max = 0;
			getMin();
			if (Min > Max) {
				strcpy(ch2, ch);
				Min = Max;
			}
		}
		while (next_permutation(ch, ch + strlen(ch)));
		for (int i = 0; i < strlen(ch2); i++) {
			printf("%c ", ch2[i]);
		}
		printf("-> %d\n", Min);
	}	
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值