poj 1502 MPI Maelstrom(最短路)

poj 1502 MPI Maelstrom

Description
BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.
Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.”

“How is Apollo’s port of the Message Passing Interface (MPI) working out?” Swigert asked.

Not so well,'' Valentine replied.To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.”

“Is there anything you can do to fix that?”

Yes,'' smiled Valentine.There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.”

“Ah, so you can do the broadcast as a binary tree!”

“Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.”

Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

题目大意:有n台机器,两两之间的数据传输速度是一样的。现在给出一张下三角形,表示机器两两之间的传输时间,x表示两机器间无法传输数据,求一号机器传输数据到其他机器的最小时间。
解题思路:先求一一号机器为起点到其他各点的最短路,然后取其中最大值,就是答案。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <queue>
using namespace std;

const int N = 105;
const int M = 5005;
const int INF = 0x3f3f3f3f;
typedef long long ll;
int n, s;
char temp[10];

struct Edge {  
    int from, to, dist;  
};  
vector<Edge> edges;  
vector<int> G[M];  

int vis[N], d[N], rec[N];
int L[N];
void init() {  
    for (int i = 0; i <= n; i++) vis[i] = 0;
    for (int i = 0; i < (n / 2) * n; i++) G[i].clear();  
    edges.clear();  
}  

void addEdge(int from, int to, int dist) {  
    edges.push_back((Edge){from, to, dist});  
    edges.push_back((Edge){to, from, dist});
    int pos = edges.size();  
    G[from].push_back(pos - 2);
    G[to].push_back(pos - 1);
}  
void input() {
    int num;
    for (int i = 2; i <= n; i++) {
        for (int j = 1; j < i; j++) {
            scanf("%s", temp);  
            if (temp[0] != 'x') {
                sscanf(temp, "%d", &num);
                addEdge(i, j, num);
            }
        }   
    }   
}
void SPFA() {  
    memset(vis,0,sizeof(vis));  
    for (int i = 0; i < N; i++) d[i] = INF;
    for (int i = 0; i < N; i++) rec[i] = INF;
    d[s] = 0;  
    rec[s] = 0;  
    vis[s] = 1;  
    queue<int> Q;  
    Q.push(s);  
    while (!Q.empty()) {  
        int u = Q.front();  
        Q.pop();  
        vis[u] = 0;  
        for (int i = 0; i < G[u].size(); i++) {  
            int v = edges[G[u][i]].to;  
            if (d[v] > d[u] + edges[G[u][i]].dist) {  
                d[v] = d[u] + edges[G[u][i]].dist;  
                rec[v] = rec[u] + 1;  
                if (!vis[v]) {  
                    vis[v] = 1;  
                    Q.push(v);  
                }  
            } else if (d[v] == d[u] + edges[G[u][i]].dist) {  
                if (rec[v] > rec[u] + 1) {  
                    rec[v] = rec[u] + 1;  
                    if (!vis[v]) {  
                        vis[v] = 1;  
                        Q.push(v);  
                    }  
                }  
            }  
        }  
    }  
}  
int main() {
    while (scanf("%d\n", &n) != EOF) {
        init();
        input();        
        s = 1;
        SPFA();
        int ans = 0;
        for (int i = 1; i <= n; i++) {
            ans = max(ans, d[i]);   
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值